Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI cDAQ 9184 software problem

Hello,

 

I have a strange software problem when using a cDAQ 9184 with 3 Modules (1 x 9207, 2x 9184). I get a problem when initializing the cDAQ after a PC reboot (without a cDAQ reboot!). The Program (build with the application builder) starts the DAQ without an error BUT no data acquisition takes place. When I have a look into the MAX Software, I see the cDAQ but the Modules are inactive (grey with red cross). After a manual reset in MAX everything works fine. I have tried to perform the reset automatically in the program (using "DAQ Reset Device.vi") but it did not help.  Have someone an idea how to fix that problem? Thank you for your help!

 

Best regards!

 

Paul

0 Kudos
Message 1 of 29
(5,804 Views)

Hello Meisspa,

 

can you please update the firmware on the cDAQ 9184.

NI cDAQ-9184 Firmware 1.5.1

How do

NI CompactDAQ Firmware

 

I hope it helps, if not please let me know.

best regards
Alexander
0 Kudos
Message 2 of 29
(5,769 Views)

Hi Alex,

 

I had updated the cDAQ to 1.5.1 when the problem occurred the first time. But it brought no improvement! Do you have another idea?

 

Best regards,

 

Paul

0 Kudos
Message 3 of 29
(5,759 Views)

Hello Paul,

 

are you using a static or a DHCP network?

What are the adresses of the pc and the chassi?

Have the pc mor then one LAN adapter?

Which DAQmx driver is in use?

Are you using a patch or crossover cable?

 

I think deactivate the other LAN adapters and try to use A DHCP network could help and

we see if its working or not.

best regards
Alexander
0 Kudos
Message 4 of 29
(5,755 Views)

Has this problem been solved yet?  I am getting exactly the same problem.  The PC has more than one LAN (which is essential), IP addresses are static (PC at 192.168.2.100 and 9184 at 192.168.2.200), using cat5 patch cable.  I updated the firmware today but no change.

 

This is URGENT!!!

 

Thanks,

Mike

0 Kudos
Message 5 of 29
(5,508 Views)

Hello Mike,

 

if its very urgent and you need a fast solution reset the device in software.

 

reset.png

best regards
Alexander
Message 6 of 29
(5,505 Views)

Hello Mike,

 

no sorry! I have also no solution for the problem. I have updated to the newest software release but this didn't fix the problem. The only work around I found was the software reset!

 

NI please fix that Bug!

 

Best regards,

 

Paul

0 Kudos
Message 7 of 29
(5,487 Views)

Thanks Alex, it seems to work, but I had to add in a 3 second delay to allow time for the modules to become available before I start using the tasks.

 

Is this a bug in DAQmx or the 9184?  Come on NI, get it sorted.

 

Mike

0 Kudos
Message 8 of 29
(5,481 Views)

Hello Dr_M,

 

i will look into the issue next week and try to reproduce it.

 

Have you contacted NI directly with this behaviour is there an Service Request?

best regards
Alexander
0 Kudos
Message 9 of 29
(5,421 Views)

Hello to all

 

sorry for the late reply. I tried to reproduce this behaviour, but it works on my side with a static IP address and three network cards in my system two are used for the cDAQ´s. I used DAQmx 14.5 with the neweset firmware 1.5.1 on the 9188 and after reboot my PXI system all cDAQ can be used directly without reseting.

 

Here the two screenshots which shows the network settings.

 

cdaq1.PNG

cdaq2.PNG

 

Hope it helps

 

 

best regards
Alexander
0 Kudos
Message 10 of 29
(5,334 Views)