Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI USB-6211 no AO generation

Solved!
Go to solution

Dear all,

 

I'm currently stuck with my NI USB-6211. I'm trying to generate a voltage waveform via an AO channel. I also want to record some signal (AI) and generate some pulse train using a counter.

I'm coding a C++/Qt software using the DAQmx ansi C library.

The Code I'm using worked, I used it extensivly on a different project (different computer). And It worked at the beginning when I installed it on the current. Then after trying to generate a pulse train it stop working  (without any error send by the card) so I tested the card in NI max and even there nothing was working (both AO and CTR). 

I noticed that when I try to start a task I observe a spike on the oscilloscope but that's all.

I tried to plug/unplug the card but without success.

 

Thanks in advance for yout help

0 Kudos
Message 1 of 2
(68 Views)
Solution
Accepted by topic author oBlanc

Well, the card started to work again... no clue about what happened.

0 Kudos
Message 2 of 2
(31 Views)