Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

NI USB 6009 pc connectivity issue

I have the USB 2009 connected to a dell pc and if I connect the DAQ my VI runs smoothly as it should. after some time when I run the VI again the data acquisition just doesn't take place, hence irresponsive. I take the usb cable out and put it into another slot and then it starts to acquire data. 


The usb 2009 never had this problem with my laptop when I was writing and testing the VI in my office. 


Any ideas?


ps: I do not have admin rights to change anything on the lab computer where this issue is taking place. 


thanks in advance, 

0 Kudos
Message 1 of 13

Windows 7?


My new computer does the same thing.  Drives me crazy... I haven't been able to find out why it behaves this way.

My old XP box never did that; I had no problems with data acquisition on XP.

0 Kudos
Message 2 of 13

I have the same problem with NI6008-USB, DAQmx9.5.1 and Windows 7 64 bits on a Dell XPS.

After the first install, all works correctly and NI-MAX does acquisition.

After a reboot of the PC, NI-MAX is not able to recognize the 6008.
Yet the windows peripherals manager lists it as active.
Sometimes, NI-MAX indicates that the 6008 is active but the Auto-test fails with error -88705. Disconnecting the 6008 has no effect and NI-MAX goes on seeing it as active after a refresh!!

The only way I found to retreive a functional 6008 is to Reinit NI configuration data in NI-MAX. But it needs to reboot the PC again and it doesn't work every time. To clear the 6008, sometimes I desinstall the driver before reinit NI configuration data. I've not identifiy a really way to succeed every time.

A lot of time lost... and no solution from NI? Yet it seems it's not a locate problem.

0 Kudos
Message 3 of 13

There are multiple possible reasons.

Try the solutions step by step and in the order they are written here.

Every single step can be the solution so check the behaviour of your USB-device after every change:


  1. Check if the "NI Device Loader" service is active.
    Why Do I Receive Error 88705?
  2. Check the Win7 USB power-saving options and disable it.
  3. Try another USB-Port (use the ones on the back of the PC).
  4. Make sure the USB-Cable is in a good condition, the connector is clean and the plugs are not under tension during operation.
  5. Uninstall MAX and install latest version (or if you had the latest: reinstall your version).
  6. Use a good quality USB-Hub with an external power source.
  7. Update your mainboards chipset-driver.


Please let me know about the results.

Best regards,



Message 4 of 13

I am totally new to all this. I don't even know if I am posting my question in the reght place.

I have LabVIEW 8.5 installed on my Del laptop. Then I installed DAQmx. I attached the USB6009 and tested it by creating a Task in MAX and it displays an appropriate analog signal in the test window. Now I am going through the "Getting Started with  LabVIEW" tutorial Chap 4 section on "Creating an NI-DAQmx Task. When I go to the Functions >>Express>>Input Palette the DAQ Assistant does not apear.


Is there something I need to do to get LabView to "see" DAQmx? 

0 Kudos
Message 5 of 13

No, you should have started a new thread instead of hijacking this unrelated one.


You didn''t say what version of DAQmx you installed. According to this, the latest version that works with 8.5 is DAQmx 9.3.

0 Kudos
Message 6 of 13

Thank you Peter for your help.


I've tested all the points you mentioned and there's no solution for my problems.

My application needs to connect one 6008 and one VISA USB PIC microcontroller. The VISA device is always seen in MAX and works properly. The problem comes only from the 6008.

I've nearly desinstalled all my NI softwares and reinstalled in hope it will solve but nothing changed.

I've proceed in this order when reinstall: Labview 8.6 Pro - NIDAQmx 8.5.1 - NIVISA 5.1.2

NIMAX version is 5.1.0f0 and was installed with DAQmx.


It's only after a reboot that MAX acts randomly and it's hard to recover a correct configuration.But when it works, I can run my Labview application all day long with many acquired data. So it's not a hard problem or a cable problem.

I've tried to run MAX with Vista Service Pack 2 compatibility or XP compatibility but in vain.


Best regards,



0 Kudos
Message 7 of 13

@Mirekal: I asume you have NIDAQmx 8.6.1 installed (not NIDAQmx 8.5.1) right?


Please make sure you also made the settings on the recovery-tab of the NI Device Loader Service (as written in the link in my solution no1)


I will continue searching for a solution but at the moment there are no other known ways to solve this issue.




0 Kudos
Message 8 of 13

So as I started this thread, I have one input. On my lab computer, I had a USB 3.0 port and I plugged into that yesterday and I checked after couple of hours and the connection still did not drop. Maybe some of the usb hubs lose connectivity. At the same time I had an external hub (without external power supply) and the USB 6009 was not recognized. I will check again today and see if the device continues to be recognized. 


hope this helps. 

0 Kudos
Message 9 of 13

Sorry to "hijack" this thred. Like I said, I am new at this and that was my first post. I did not know how specific the threads were. I will start a new one next time. Thanks for your help. It looks like have an incompatability problem. I have LabVIEW 8.5 and DAQmx 9.3.5. I guess I will need to upgrade my LabVIEW software.

0 Kudos
Message 10 of 13