Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI MAX is crashing

I am trying to get a USB-6009OEM board running. Originally I had NI-DAQmx 8.0 running, but when I opened NI-MAX (version 4.1) the device would not show and the LED on the USB board did not blink. Windows XP however seemed to recognize the device, because I hear the usual 3 beeps and the "found new hardware" wizzard does not appear. This was possibly due to the device not having the correct firmware, but there did not seem to be an option in NI-MAX to dowload firmware. In the Windows XP device manager a device appeared called "NI firmware downloader 6xxx", but nothing else seemed to happen when the USB port was plugged in. I decided to download and install the latest version of NI-DAQmx (v8.3) and try if that would give me better results.

Now when I plug in the USB board the LED on the board blinks, but when I start NI-MAX it crashes and there is no way to assign a device name etc. to the board, so I cannot write a Labview program for it. I wanted to see if the latest version of NI MAX would be more compatible, but I do not see it on your website. Can you point me in the right direction for a solution.

Other software on the computer is:
NI Instrument IO Assistant
NI Labview 7.1
NI Labview Application Builder 7.1
NI Labview Run-Time Engine 7.0
NI Labview Run-Time Engine 7.1
NI Measurement and Automation Explorer 4.1
NI Measurement Studio for VS2003 Update 7.1.0.308
NI PXI Platform Services for Windows 2.1.0
NI VI Logger 2.0.1
NI-488.2 1.74
NI-DAQ 7.2, Tradional
NI-DAQmx 8.3
NI-VISA 3.1
NI-VISA Runtime 3.1
NI-VISA Server 3.1
NI-VXI Support for Labview 1.2.1f0

Thanks -- Gerard
0 Kudos
Message 1 of 10
(5,507 Views)

Hi Gerard,

As far as the firmware on the 6009 is concerned, the USB-6008, USB-6009, and the USB-6501 ship with installed firmware that allows you to use NI-DAQmx Base. The first time one of these devices is plugged into a Windows machine with NI-DAQmx 7.5 or later installed, the NI-DAQmx driver automatically installs the firmware necessary to use NI-DAQmx, which disables the NI-DAQmx Base firmware.

Here is a Knowledge Base Article that talks more about the firmware.

Firmware on USB-6008/6009/6501

Also, could you please elaborate on "but when I start NI-MAX it crashes ". Does it throw some kind of error and then crash or does it just shutdown. One thing you can try is to actually uninstall the driver from Windows Device Manager by right clicking on it and uninstalling it and then plugging the device in again and letting Windows detect the device and install the drivers for it.

The latest version of MAX is just installed with the DAQmx driver that you downloaded, which means that if you downloaded the latest version of the DAQmx driver and installed it, you probably have the latest version of MAX installed as well.

Regards,

Raajit | Applications Engineer | National Instruments

 

 

Raajit L
National Instruments
Message 2 of 10
(5,477 Views)
Hi Raajit,

I read that Knowledgebase article before I upgraded to Nidaqmx 8.3, but this is what happened under NiDaqmx 8.0

1) Open MAX (Start >> Programs >> National Instruments >> Measurement & Automation).
This used to work without a problem.
2) Select Tools >> NI-DAQmx Configuration >> NI-DAQmx USB Driver Selector.
The Ni-DAQmx USB Driver Selector was grayed out. I could not select it.

This is why I upgraded to Nidaqmx 8.3.
Now NI MAX Crashes. The exact error upon starting the software reads:

"NIMax has encountered a problem and needs to close. We are sorry for the inconvenience. If you were in the middle of something, the information you were working on might be lost. Please tell microsoft about this problem. We have created an error report that you can send to us. we will treat this report as confidential and anonymous. To see what data this error report contains. click here."

When you "click there" the window reads:
Error signature-----------
AppName: nimax.exe         AppVer 4.1.0.3001 ModName nihdvui.mxx
ModVer: 5.1.0.161      Offset: 0001b593

The exception information is:
Code: 0xc000005      Flags: 0x00000000
Record: 0x0000000000000000      Address: 0x0000000001bfb593

and a lot of other stuff that I do not want to copy unless this is helpful to you. I can e-mail you the Windows XP error log that would be send to Microsoft if you want (I do not see a way of attaching this file to this post).

It seems to me that re-installing NI-MAX is possibly the easiest solution to this problem, but I cannot find the place where I can download NI-MAX.

Thanks -- Gerard
0 Kudos
Message 3 of 10
(5,469 Views)
If you downloaded the latest version of the DAQmx driver (8.3.1) and installed it, you'll have the latest version of MAX installed as well.
0 Kudos
Message 4 of 10
(5,467 Views)

Hello Gerard,

This might have occurred because of a corrupt installation of the DAQmx 8.3 driver.  What you could do is uninstall NI-MAX and reinstall it, or even uninstall DAQmx 8.3 and reinstall it.

You can uninstall MAX by going to Start >> Settings >> Control Panel >> Add or Remove Programs.  From the list of software that comes up, go to National Instruments Software and click on Change.  This will bring up a list of all NI software.  Select NI Measurement & Automation Explorer and click on Remove.  The dialog box that opens will list any software components that depend on MAX.  Take note of these because you will have to reinstall them.  Click on the Remove All button to uninstall MAX and all dependent software. 

After everything has been uninstalled, do a fresh installation, and let us know if you are still having this problem.

Best Regards,

Raajit

Raajit L
National Instruments
Message 5 of 10
(5,452 Views)
Hi Raajit,

Before I already tried the "Repair" function in the control panel, but it continued to crash. Per your suggestion I performed a "Remove" followed by a re-install. Now NI-MAX starts up, but when I click on "My System>Devices and Interfaces" I get the following error message title: "MAX Database connection error" with the explanantion: "There was a problem connecting to the database. Please restart your computer and contact National Instruments if the problem persists." I have re-started the computer and the problem persists. What's next.

Thanks -- Gerard
0 Kudos
Message 6 of 10
(5,447 Views)

Hello Gerard,

Here is an article that talks about the error that you are facing now. It talks about the different reasons why this error might be occurring. Hopefully once you follow these steps, you will not have any more errors Smiley Happy.

Why Do I Get a Measurement & Automation Explorer (MAX) Database Connection Error?

Regards,

Raajit Lall

Applications Engineer

National Instruments

Raajit L
National Instruments
Message 7 of 10
(5,415 Views)
Hi Raajit,

I removed Ni-MAx from the blocked programs list in McAfee and that made everything work properly.

Thanks for your help. -- Gerard
0 Kudos
Message 8 of 10
(5,410 Views)
                                                                                                                       can any 1 say what is d reason
0 Kudos
Message 9 of 10
(4,650 Views)

There is KB that talks about potential reasons mentioned above.  FYI you should probably create a new thread for new issues.

 

Why Do I Get a Measurement & Automation Explorer (MAX) Database Connection Error?

 

Have you tried these things?  Are you still getting the error?  What version of NI-DAQmx are you using?  When did this start?  Can you give us more details?

 

Regards,

 

Neil S.

Message Edited by Neil S. on 10-01-2008 12:22 PM
0 Kudos
Message 10 of 10
(4,621 Views)