Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

NI 9266 no output, gives code 200046, but self-test completes successfully

Go to solution



I have a NI-9260 that I am trying to get a signal out of. I have it hooked to an oscilloscope for testing. I ran the self-test from the NIMAX panel and it came out ok but when I run the test panel I get the following warning and nothing is sent to the scope. I have tried both channels and different cables. 




My questions are: 1) Should this work without the calibration? I assume it would. 2) Is there a better way to validate that this device is working?


All the best, 


0 Kudos
Message 1 of 2
Accepted by topic author Austin-Downey

If the calibration is corrupt, then the module won't have a way to know how to scale the unsigned integer code it receives into actual voltages.  You'll either have to calibrate the device yourself if you have the qualifications and appropriate hardware or send it to NI or a metrology lab to calibrate it.


Is this a brand new device?  Has it been working before?  Did you do anything (like attempt to calibrate it) that could have caused a corrupt calibration on the EEPROM?  Was there an electrical event like a power surge recently?  The EEPROM won't typically just fail unless you've written to it loads of times or there was some kind of electrical event that could have fried something.

0 Kudos
Message 2 of 2