Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

NI 9218/NI 9983F: Error -200077 when trying to measure 4-20mA current

Go to solution

I'm trying to measure the output current of a sensor. It is between 4mA and 20mA.

I'm using the NI cDAQ-9171 with the NI 9218 Unit and an additional shunt resistor, NI 9983F (for +- 20mA current measurement):


In the "Start Task" vi does an error occur:

Error -200077 at DAQmx Start 7220001


Property: AI.Max
Requested Value: 20,0e-3
Value must be bigger than: -6,644518e-3
Value must be smaller than: 6,644518e-3


Device: cDAQ1Mod1

Task-Name: _unnamedTask<44>



I tried several examples made by NI or other users but nothing worked!


My current measurement vi.My current measurement vi.


Thank you in advance!

0 Kudos
Message 1 of 3
Accepted by the_dani

Hello the_dani,


which driver you are using with DAQmx 16.1 and newer this should not happen, with an older driver the worlkaround is to configure the adapter to NI 9983D.

best regards
0 Kudos
Message 2 of 3

Thank you, I updated DAQmx and it works!

0 Kudos
Message 3 of 3