Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI 9208 Unsupported Module

I have a cDAQ 9174 with an NI 9208 spring terminal module that installs itself as unsupported when connected to a PC. The PC is running Windows 7 with LabVIEW 2009 (32-bit) and DAQmx 9.7. What steps should I take to get the computer to recognize the module?

0 Kudos
Message 1 of 10
(6,258 Views)

Hi DBBoman,

 

That's quite strange, seeing as though you have all of the requirements.

Did you make sure to keep the module unplugged from the PC whenever you downloaded the driver?

Did you install DAQmx after having installed LabVIEW?

Is your module properly seated in the chassis?

Have you tried any other slot?

 

It seems like this is an issue that's come up before and we've made a KB about it here: http://digital.ni.com/public.nsf/allkb/1A7587205357457A86257EAD0001DE7E

Aulia V.
0 Kudos
Message 2 of 10
(6,222 Views)

Hi DBBoman,

 

I'm sorry to say that I was misinformed. Through other documentation, I have found that the 9208 Spring Terminal modules are not supported in DAQmx. It is documented here: http://www.ni.com/product-documentation/10622/en/#toc2

 

Again, I apologize for the confusion and wish you the best of luck.

Aulia V.
0 Kudos
Message 3 of 10
(6,203 Views)

To clarify, spring terminal variants of the 9207, 9208, and 9209 were released a few months ago with NI-RIO support. NI-DAQmx support is planned, but not currently available.

 

New versions of DAQmx can be found at ni.com/drivers, and added module support will be documented in each version's readme.

0 Kudos
Message 4 of 10
(6,197 Views)

Hi KB,

Can you direct me to where it is documented that the spring terminal versions of these modules are not supported (or even exist for that matter)? The link that you provided does not even show the NI-9207 or 08 as a spring terminal version for compactDAQ or compactRIO. Nothing in the NI-9207 data sheet nor getting started guide makes any mention of the spring terminal version as being not compatible with campactDAQ.

 

I have a NI-9207 (spring terminal) installed in a NI-9184 chassis and it is coming up as unsupported module. This configuration was purchased through the NI compact daq advisor tool in December 2016. At the time the module was listed as supported in campactDAQ and freely available to select and purchase through this tool. After receiving the module and having it show up as an unsupported module, I spent a week troubleshooting with tech support who determined that the module was defective and issued an RMA. I have since received another module which also returns the unsupported module error in NIMAX.

After reading your post, I returned to the CDAQ advisor tool to check compatibility, and the spring terminal module is no longer available. I can find no mention of the spring terminal version of this module unless I go through the compact rio advisor. The product page:

http://sine.ni.com/nips/cds/view/p/lang/en/nid/209885#productlisting

does not even mention a spring terminal version of the 9207 (it does however mention a screw terminal version).

 

If you could provide some guidance on this matter it would be greatly appreciated.

 

Thanks!

Justin

 

 

0 Kudos
Message 5 of 10
(6,131 Views)

Justin

I'm sorry to hear about all the trouble. Personally, I don't know much about the System Advisors, and I have yet to reach out to the teams that would document module support (or lack thereof).

 

At this point in time, my recommendation would be to get in touch with our Customer Service team (Other Questions) about exchanging your module for a screw terminal version.

0 Kudos
Message 6 of 10
(6,116 Views)

Hi,

I am having a similar problem with a 9209 spring terminal module in a cDAQ-9171 chassis being reported as an unsupported module in DAQmx 16.0.1

 

The product support page http://www.ni.com/product-documentation/10622/en/#toc2 marks it as unsupported in 14.5 "NI-DAQmx 14.5 (NI 9209 Spring Terminal variant not supported)". However in the reademe for version 16.0.1 the NI 9209 is listed as supported with no qualifier as to which version.

 

This gives the seemingly false impression that whilst it was not supported in version 14.5 it is now. If it is not supported then I feel this information should be much more visible before purchase.

 

Do you have a date for support in NI DAQmx or do I need to return and exchange for the DSUB version.

0 Kudos
Message 7 of 10
(6,082 Views)

I am having the same problem with this module (NI-9208) mounted at a cDAQ-9179. Is there any update for this issue?

0 Kudos
Message 8 of 10
(5,465 Views)

FBro--

 

The spring terminal variant of the 9208 (as well as the other modules mentioned in this thread) are now officially supported by DAQmx drivers 17.1 and later. This KB details the modules affected. 

 

Best of luck!

Claire M.
Technical Support
National Instruments
Certified LabVIEW Developer
Message 9 of 10
(5,454 Views)

Thank you, Claire! Updating the drivers solved the problem!

0 Kudos
Message 10 of 10
(5,444 Views)