Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue: DAQmx AI channels strange behaviour

Solved!
Go to solution

Hello,

 

since a few days we are trying to solve an issue which occure on both of our testing systems.

After 2-3 hours the AI channel (differential) suddenly shows wrong volt values.

 

We have an TDK Lambda with 8V connected to the AI0+ and AI0-. After 2-3 hours the value suddenly goes down to about 3.6V. If I measure with a DMM by hand I still measure 8V but the AI0 says 3.6V.

Config:

- Differential

- Continous

- 2 Samples

- 1000 Hz

 

Maybe the PXIe-6345 is broken, but unfortunately this kind of issue happens to both of our testing systems.

 

Does anybody have an idea how to find the issue?

 

Kind regards

p_dieng

0 Kudos
Message 1 of 3
(174 Views)

I would suspect some grounding issue. Please share the "exact" schematic of connections and the code you're using (at least a simplified version that can reproduce this issue).

 

To rule out any software related issues, please try the shipping examples to repeat your experiment.

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF

New to the forum? Please read community guidelines and how to ask smart questions
0 Kudos
Message 2 of 3
(138 Views)
Solution
Accepted by topic author p_dieng

I have already solved the issue. This phenomen was caused by our security tool and CANoe. Means our sec tool did something to CANoe and CANoe did something to the DAQmx driver.

 

Procedure with security tool:

1. I started CANoe measurement

2. Parallel to it I started NI MAX (AI data acquisition with 2 Samples / 1kHz / Continous).

Result: After 1-3 hours the AI channels returned wrong volt values in NI MAX

 

I thought that they don't have something in common but for some reason, when I closed CANoe, the AI channels have worked perfectly fine over the weekend.

 

Procedure without security tool:

Without the security tool CANoe and DAQmx driver work as they should.

 

Next time I will definitly deinstall the sec tool first befor asking here. Sorry for the inconvenience.

 

Kind regards

p_dieng 🙂

0 Kudos
Message 3 of 3
(120 Views)