Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

I cannot get two USB cards worked at same time

Go to solution

I am using Labivew 8.6 to program an application by using NI UBB-9211 and USB-6211 connecting to two USB ports on my PC in order to measure both temperature and pressure (voltage) at same time. Also I need to generate two AOs from USB-6211 to drive my motors. I tested two cards, they are OK. But when I program them together, I only get 9211 worked, an error message poped from DAQ of USB-6211. Could you please help me on this? any advice or VI sample/examples would be greatly appreciated. Thank you in advance!

0 Kudos
Message 1 of 6
Accepted by navistar

Hi navistar,


It sounds like you should be able to do what you are trying to accomplish. Can you post some information about the error you are receiving? Are you using the lower level DAQmx VIs or the DAQ Assistant in your application? You can post a screen shot of your code as it is merged together and the troubleshooting would be easier. Are you using any triggering for your application? we do have examples in the Example Finder (Help>>Find Examples) under Hardware Input and Output>>DAQmx. These examples are a good place to start building your application. If you already have working code for each instrument and you are having issues combining them, it might be easier to work with where you are at as opposed to starting it all over.

Steve B

Message 2 of 6



Thanks a lot for your advice. Here is the VI I am working on, I am basically trying to get the two cards (USB-9211A and USB-6211 connecting to different PC USB port) working, but I am struggling ...


Your help is greatly appreciated!






0 Kudos
Message 3 of 6

Hi navistar,


The program looks to be well on its way. Can you post some information about the error you are receiving? I would like to know the error code and error message. This should pop up after the VI is finished running. Does the error message relate to the Auto Zero? You may have an issue because you are automatically setting this value for both devices. If you are not receiving an error then I would recommend that you try to right-click on the Y-axis of your graph and choose AutoScale Y. You may be returning data but it might not be fitting on the display of the graph as it is currently set. Let me know about the error and if auto scaling helps.

Steve B

0 Kudos
Message 4 of 6

Hi Steve,


Thank you for your help. The program only runs a couple loops then an error appeared in second loop, the error message reads:


Measurements: Attempted to read samples that are no longer available. The requested sample was previously available, but has since been overwritten.

Increasing the buffer size, reading the data more frequently, or specifying a fixed number of samples to read instead of reading all available samples might correct the problem.

Property: RelativeTo
Corresponding Value: Current Read Position 

0 Kudos
Message 5 of 6

Hi navistar,


This issue is occurring because you are overflowing the read buffer for your USB-6211 as it is acquiring pressure data. Your sample rate is set to a default of 10k Samples/channel/second. You may be using a different rate, but this in combination with the number of samples per channel set for your timing and your DAQmx Read is causing the buffer to overflow. I would recommend that you try lowering your sample rate or increasing the number of samples per channel that you read for each loop iteration to a value greater than 100 where it is currently set. You should be able to find a balance in your settings that will allow you to run your program without an error.


You can check the number of samples in the buffer using a DAQmx Read Property Node set to Status>>Available Samples Per Channel.

Steve B

0 Kudos
Message 6 of 6