Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

I can not import a lvm file into signal express

I have been using signal express lately to log and evaluate some tdms files from my DAQ. I am running into trouble though from importing some previous .lvm files which I logged from the same DAQ. I used a standard VI for writing to a text file in Labview.
 
Anytime I import a LVM file I get an error stating "incorrect file type" after I specify the import file path in the load from LVM choice.
 
Any ideas?
 
EB 
0 Kudos
Message 1 of 8
(3,901 Views)

Hello erb174,

If you use the "Save to ASCII/LVM Express VI" function to save the signal into an LVM file, Signal Express will generate an error message according to the description you reported (the file is of "Incorrect file type"). This is a known bug and it will be fixed in the next version of the software. You can temporarily solve the problem by doing a Save to ASCII (text file) instead in LV. Save to LVM actually works in SE, so we're defering for now.

Regards

Matteo
Message 2 of 8
(3,891 Views)
When will this new software version be available?
0 Kudos
Message 3 of 8
(3,887 Views)
This information it isn't yet available, but this behaviour seems to have an high relevance. So we could expect that it will be solved as soon as possible.
 
Cheers
Matteo
0 Kudos
Message 4 of 8
(3,884 Views)

Hi EB,

 

I just had the same problem on my machine:

 

I am using LabVIEW 8.6 and wrote some example values to a LVM-File. I tried to import this file into SignalExpress 3.0 and got the error "invalid file type".

 

Well, I took a closer look (using Notepad.exe from Windows) into the LVM-File and compared it to a generated by SignalExpress one. Examining the header, I found out, that LabVIEW 8.6 is using the "WRITER_VERSION 2" and "READER_VERSION 2", but SignalExpress uses 0.93 and 1.

 

So there was a major change in LabVIEW 8.6 in writing LVM-Files. I manually changed the reader version from 2 to 1 in line 3 of the LVM-File:

 

 

 

Afterwards, SignalExpress did successfully import the modified LVM-File.

 

Be careful using this workaround, because SignalExpress could misinterprete the data in the file due to the major version change of the LVM-format.

 

 

Best regards from Germany

 

Message Edited by MarianMO on 05-04-2009 01:47 PM
Marian Vorderer
Message 5 of 8
(3,736 Views)

The difference between version 1 and version 2 is the addition of the Decimal Separator field.  This properly supports local standards by using either a period "." or comma "," for the decimal indicator.  This version of LVM was introduced in LabVIEW 8.6.  As MarianMO said, it is relatively easy to manually convert a version 2 file to version 1.  Do the following:

  1. Change the Reader_Version from 2 to 1
  2. If the Decimal Separator field is a period, you are done. If not, continue
  3. Change the Decimal Separator field to a period
  4. In the header, change all comma decimal separators to periods.  You should probably do this manually to avoid overwriting other text fields
  5. In the data section, use the "change all" feature of your text editor to change all commas to periods.
 The file should now read correctly in SignalExpress (and LabVIEW).  We apologize for this problem.
Message Edited by DFGray on 05-04-2009 08:44 AM
Message 6 of 8
(3,728 Views)

I seem to be having the same issue but unfortunately your work-around doesn't seem to be working for me. I don't suppose you have any other ideas?

 

Cheers,

Andy

0 Kudos
Message 7 of 8
(3,441 Views)

Apologies, for reasons know best to the LabVIEW gremlins, your work-around has now started working. I have no idea what that was about...

 

Andy

0 Kudos
Message 8 of 8
(3,402 Views)