Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

How to auto-initialize an Ethernet cDAQ (9188) at startup?

Go to solution



I have a LabVIEW program that runs DAQmx Tasks (preconfigured via NI MAX). The hardware is a cDAQ-9188, connected directly to the laptop via Ethernet cable. Both machines have static IP addresses (same subnet).



Each time we turn on the machines, NI MAX reports that the cDAQ-9188 is Reserved and Running. However, the C-series modules are reported as Not Present (error code -88705: "The specified device is not present or is not active in the system. The device may not be installed on this system, may have been unplugged, or may not be installed correctly")


As a result, the LabVIEW program throws an error, because the physical channels required by the DAQmx Tasks are not found.




Each time we turn on the whole system, we go to NI MAX -> My System -> Devices and Interfaces -> Network Devices -> NI cDAQ-9188 and click "Self Test".


The test always succeeds, and seems to do some kind of initialization behind the scenes. After this step, the LabVIEW program runs without any issues.



  1. Is this behaviour expected? If not, what could cause this?
  2. Is there way to automate this initialization, so that the user doesn't need to click "Self Test" after every cold boot?
Certified LabVIEW Developer
0 Kudos
Message 1 of 7
Accepted by topic author JKSH


you can programmatically do a Self-Test.


I wouldn't say it is an expected behavior. What helped here, was a LabVIEW and DAQmx repair. But before you do that I would make sure you have the newest drivers.

Message 2 of 7


I have a similar problem, but solution provided here does not work for me.



When computer is turned on, cards related to the device (cDAQ-9189) are disabled.


When I run a custom program it throws me "Device cannot be accessed."

Status Code: -201003



Runing self-test or reset the device programatically don't fix this. I just have to click on each link in

NI MAX software for it to becomes available:




How do I do this programaticaly, so my software can run on boot?

Message 3 of 7

Hi alex_mdr !


I have the same problem to init programmatically.

Have you already got a solution?

0 Kudos
Message 4 of 7

Hello alex_mdr and lupo,


You might try making a new thread for this question. The original post is kinda old and by creating a new thread you could potentially get more user exposure to your question. 

Gerald M.
Applications Engineer
0 Kudos
Message 5 of 7
Accepted by topic author JKSH

If I remember correctly, this is what I did:

  1. Reset the NI MAX database: (WARNING: This will delete all your devices, Tasks, scales, and other settings in NI MAX!)
  2. Re-add and re-configure the NI-9188

After that, the errors stopped occurring so I didn't need to do Self-Tests anymore.


(Post a reply here if this solution works for you)

Certified LabVIEW Developer
Message 6 of 7


Thanks for your answer.

Resetting NI MAX helped to make my problem reconstructable.

So I have solved the issue (mixture of Windows behavior and own bug)

0 Kudos
Message 7 of 7