Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 201401 when Add Device on cDAQ-9188

I am trying to connect to a cDAQ-9188 with MAX.  This is a chassis that I've connected to before.  After initially receiving an error when trying to reserve the chassis, NI tech support asked me to perform a Reset Configuration Data in MAX, which I did.  Now I am trying to perform an Add Device in MAX, and when I do I receive error 201401.

 

I am using MAX 5.0.0f1.  The 9188 has firmware version 1.2.0f1.  I am using a Win7 machine.  I am connecting with an ethernet crossover cable directly from laptop to chassis.  Windows Firewall is off.  I am able to ping the chassis successfully.  MAX is able to communicate enough to determine chassis Model, SN, System State and Firmware.

 

Please see 2 screenshots attached.

 

If you have any suggestions, please let me know.  Thanks.

Download All
0 Kudos
Message 1 of 16
(11,498 Views)

Hi rick.s,

 

I did some research and I would like to know the daqmx version that you have. I strongly recommend you to have the latest one (9.4) that you can find here. This KB article describes some troubleshooting steps that you might follow to get your chassis up and running.

 

Regards,

steve.bm
AE | NI
0 Kudos
Message 2 of 16
(11,482 Views)

I have daqmx version 9.4.  I'll look at the steps in the troubleshooting article.

0 Kudos
Message 3 of 16
(11,471 Views)

I have the same problem with cDAQ 9191.Did you solve it?

0 Kudos
Message 4 of 16
(11,461 Views)

I have not solved the problem.

0 Kudos
Message 5 of 16
(11,455 Views)

Hey Guys-

 

I'm sorry to hear that you are both having problems.  Hopefully you can get some better suggestions to help dig in.

 

The symptom you describe sounds like some traffic (like mDNS identication, used for discovery) are making it through, but some other NI-specific packets are not (for example, querying the hostname or other properties of the device, which are reported and queried in an NI-specific way).

 

I had an interaction on a recent thread where a user was getting stymied by VMWare virtual adapters.  I linked to an NI KB that has a list of troubleshooting suggestions that we have compiled from other users that ran into troubles.  Please check out that thread and KB to see if you find anything helpful.  If not, post back here and we can try to dig deeper with your specific setups.

Tom W
National Instruments
0 Kudos
Message 6 of 16
(11,449 Views)

Hi! I have solved the problem. Connect the computer to the device via ethernet cable then you just need to change the IP adress on your PC, set the IP as the same IP  of the device. After that just follow the instructions. Smiley Happy

0 Kudos
Message 7 of 16
(11,420 Views)

Hi ro84-

 

I would like to clarify your post since it seems unlikely to work for other users.  If you choose to use a static IP configuration, you should set your host and device to IP address on the same subnet, so they will be similar (how similar depends on your subnet mask), but they should not be exactly the same.

 

Alternatively, you can leave your 918x or 9191 chassis in 'DHCP or Link-Local' mode and your Windows host to 'Obtain an IP address automatically...', then both should fall back to link-local addressing (169.254.xyz.abc) and they should be able to communicate successfully when directly cabled in this configuration.

Tom W
National Instruments
0 Kudos
Message 8 of 16
(11,412 Views)

I have narrowed down my problem to be related to our company network and the configuration of my PC for this network.

 

I tried MAX on a different computer with Win7 and it worked fine.

 

I have worked around my issue by placing the chassis on our network and configuring the chassis for DHCP only.  I can now communicate with it through our network.

 

Thanks for your help.

Message 9 of 16
(11,408 Views)
I am having this same issue. I have both the computer and the cDAQ on the same isolation network, firewalled off from the rest of the company network. I am able to detect the cDAQ, modify network settings in MAX, and access it's web interface, but I get this error when I try to add the device.

Can you expand upon what network settings were causing the problem? My only hunch so far is that it has something to do with the fact that the network's DHCP does not register host names and there is no DNS either, so addressing by host name will not work. Does the this device require host name resolution or can it function without it?
0 Kudos
Message 10 of 16
(10,142 Views)