Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Error -200284 occurred at DAQmx Read



  I am using : NI DAQCard-6036 E with latest Labview version.


I tried to access input channel of DAQ but it gives error message: 

Error -200284 occurred at DAQmx Read (Analog 1D Wfm NChan NSamp).vi:1


Possible reason(s):


Measurements: Some or all of the samples requested have not yet been acquired.


To wait for the samples to become available use a longer read timeout or read later in your program. To make the samples available sooner, increase the sample rate. If your task uses a start trigger,  make sure that your start trigger is configured correctly. It is also possible that you configured the task for external timing, and no clock was supplied. If this is the case, supply an external clock.


Property: RelativeTo

Corresponding Value: Current Read Position

Property: Offset

Corresponding Value: 0

Task Name: _unnamedTask<6> "


I tried the first example on acquiring signal through DAQ but again I get the same error.


I am able to use DAQ with Matlab simulink but not with labview.  I would like to use Labview can anyone help me to solve this issue?


Thanking you. 

0 Kudos
Message 1 of 8
Do you read a large number of samples with a slow samplerate? If so, calculate the time it takes to read all the samples and increase your timeout at the DAQmx
0 Kudos
Message 2 of 8

Even if I use MAX it gives the same error. There is no trigger used , enough time is given to read (sample rate: 1k and number of samples 100) though it gives this error.


0 Kudos
Message 3 of 8

Dear Sinbad,


Thank you for your reply. There are multiple reasons that can cause this problem, to determine our problem here I have some tests and questions;

- can you try 1000 Hz / 1000 samples in MAX (testpanel)?

- does the DAQ card pass the self test in MAX?

- is it possible to try another slot and if this doesn't work another PC (only test in MAX)?

- what operating system do you use, did you install the latest service pack? There are some known issues (security) which can cause this warning.

- what version of DAQmx are you using (you can determine this in MAX under software)

- what kind of PC are you using? (hardware configuration)


I'm looking forward to the results of these tests,


Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 4 of 8

Hi Martijn


  I still couldn't know the reason why DAQ doesn't do continuous or countable acquisition (by setting samples to acquire and rate of acquisition properly ) on HP computer.

 However DAQ worked properly with another pc from Dell. So my problem is apparently solved. I will come back to this configuration later and inform you.


Thanking you.




0 Kudos
Message 5 of 8

Hello Sinbad,


thank you so much for your reply. I'm glad everything works in another PC. I just noticed the fact that you are using a DAQcard? Are you using this in a PC with a PCMCIA-PCI converter? Or are you using a laptop? I bumped into a lot of troubles with these kind of convectors, so it is possible that this has something to do with it.  

There can also be some performance issues on the PC bus, so looking to the chipset drivers can be a answer to your problems. If this is the case SW timing (taking one sample on demand) shouldn't be a problem; when you do HW timing (define sample clock and rate and take N samples) problems like this can occur.


Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 6 of 8

Thank you for your mail.


Computer details: HP XW4600 (bought in May 2008)

Intel(R) Core(TM)2 Duo CPU E800@3.00 GHz 4 GB RAM , Intel X38 Express performance chipset ,



I have NI DAQCard-6036E 16-Bit, 200 kS/s E Series Multifunction DAQ for PCMCIA.

I did several re-intallations of both Labview and Windows but it couldn't solve the problem of continuous or coutable acquisition.



0 Kudos
Message 7 of 8

Hello Sinbad,


again; it is possible that the PCMCIA to PCI can cause these kind of problems. I bumped into a lot of issues with these kind of adapters.


Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 8 of 8