Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1003 VI broken because DAQmx create Channel DO-Digital Output.vi broken in RTE !!

Solved!
Go to solution

Hey

VI_BROKEN (0): [VI "DAQmx Create Channel (DO-Digital Output).vi" (0x02a8c080)]

Not when IDE installed on PC. So: no problem when running on PC where LabVIEW developement is installed. Tried LV2014 & LV2016. Both give same problem.

How can I proceed?

Tried everything.

Must be somenthing in my build. (remove blockdiagram or ...) because many other same likewise LLBs work on the same computers.

thx,

Koen.

In attachement, screenshot of installed NI packages.

0 Kudos
Message 1 of 5
(1,544 Views)

According to this table, DAQmx 14.0.0 is not compatible with LV2016. But it should with LV2014.

Have you installed the expected LV RTE on the computer running the EXE ?

0 Kudos
Message 2 of 5
(1,531 Views)

yes.

next step will be to try out to build my llb with remove blockdiagrams not active. Last try I did was to activate debug option.(no custom VI props)

I will also check in my llb possible conflicts. But the VI where the fault is generated is not broken on the PC where LabVIEW develop is installed.

It must be something in my build, because other builds with same version and also using DAQmx runs fine, but this llb not.

I will also try to copy a good project and insert all my VIs of that "bad" project into that copied project. Should solve it I think. But will be time consuming...

rgrds,

Koen.

0 Kudos
Message 3 of 5
(1,503 Views)

works fine on newly installed LV2016 PC with DAQmx used. It must be mismatch between our/my own framework using the LLB.

Without rebuilding the LLB it works on that new PC. Difference between new PC and old ones is the build framework we use. I know that when the framework has loaded same named subVIs as in LLB, the LLB ones are not reloaded, but the already loaded framework subVIs are used.... I will now try the new framework on the old PCs... Hopefully solved.

0 Kudos
Message 4 of 5
(1,482 Views)
Solution
Accepted by topic author kdCMC

reinstalled LV2016 IDE on my PC incl. daqmx device drivers -> rebuild the LLB and now works fine.

Had to be a broken do daqmx IDE vi.

0 Kudos
Message 5 of 5
(1,413 Views)