Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Data acquisition for two LVDTs using NI-9205

Solved!
Go to solution

Hi,

 

I am currently using NI-9205 for Data acquisition for two LVDTs.

The LVDTs have 3 wires, one for Output (0-10V), one is Supply Volts DC and one is 0 Volts DC.

I have seperated the 0 Volts wire to 2 wires, one connect to the negative of power supply and another connect to the NI 9205. I am using the differential model of the NI-9205 (say Output connect to AI0 and one wire from 0 Volts connect to AI8). 

The problem is these two LVDTs can works pretty well when I only connect one of them to the module. But when I connect them to the module the same time, say one LVDT connect to AI0 and AI8 and one LVDT connect to AI1 and AI9, these LVDTs can not work properly.

Are there any wrong connections in my configuration?

 

BTW, can I use other modules like NI 9220 for may case? because I may need a higher smpling rate, and NI 9220 have sampling rate seperately for each channel but NI 9205 share the total sampling rate. If not, what module can I use?

 

Sorry for my weak background in electricity. I have refered to the Getting Started Guide and Datasheet of these modules but it is hard for me to understand them. Any help is much appreaciated!!!

 

Best Regards,

Roy

0 Kudos
Message 1 of 5
(761 Views)
Solution
Accepted by Roy19

Hello Roy,

 

Assuming you are powering both sensors with the same power supply, the 0V is common for both of them so you can read thier signals in single ended mode, there should be no problem reading both sensors, maybe you have something wrong in the connection.

 

Saludos.

0 Kudos
Message 2 of 5
(724 Views)

Hi Saludos,

 

Thank you for you help.

Yes, I power two LVDTs using the same power supply. Then I connect these two LVDTs to differential pairs of the module (say AI0 and AI8, AI1 and AI9).

Could you please tell me why I can not use differential mode to acquire data from two LVDTs?

 

Best Regards,

Roy

0 Kudos
Message 3 of 5
(706 Views)

I didn't mean you can't use differential mode just that you don't have to since both sensors share the same ground from the power supply.

Take a look at this picture from the user guide:

Antoniooh_0-1622205465961.png

On figure 2 you can see how they recomend how to connect grounded diferential signals on the NI9205.

Hope this helps.

Saludos.

0 Kudos
Message 4 of 5
(691 Views)

Thank you Saludos,

 

I have reconnected those sensors again today and they works pretty well. I guess yesterday there is something wrong in my connection.

 

I have another question hope u dont mind. I am using the same power (24 V DC of the NI chasis) for these 2 LVDTs. Now I seperated the 0 Voltage wire to 2 wires, one goes to negative of the power and the other goes to the moddule (I have another Voltage output wire connecting to the module, so that they form a differential mode).

So if I use single ended mode, does it means I dont need to seperated the 0 wire to 2 wires?

 

Best Regards,

Roy

0 Kudos
Message 5 of 5
(688 Views)