Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

DAQmx Error -209860 Conflicting Coherency Requirements in networked NI 9189 cDAQ

Basic Setup: NI Max v.21.0 installed. Using DAQmx ANSI C 64 bit static library. Hardware I have setup are two NI 9189 cDAQ chassis with modules NI 9401 and NI 9485 installed. The chassis are configured in a line topology to a host computer when issue presents.



I am attempting to do a very simple digital write to the modules on each chassis. I am able to create tasks and to create DO channels. When I attempt to start the tasks, either by enabling auto start with the digital write function, or by manually starting the task one of my chassis returns this error: 


"DAQmx Error: One or more devices could not be added to your task because they have existing coherency requirements that conflict with the new requirements of your current task. Stop the task(s) that use devices in this task and try running it again. Task Name: 9401Write. Status Code: -209860."

As soon as I reduce my devices to just a single chassis connected to the host computer I am able to execute everything just fine. When I reconnect the secondary device this problem appears. This problem occurs in the same cDAQ and does not exhibit in the second piece of hardware that I have connected regardless of the physical network configuration (which chassis is connected to the host and which is daisy-chained.

When opening the NI Max software I can see both devices just fine with no obvious error states. I am able to open test panels for each chassis, however when I attempt to start a test panel for the chassis which was generating the error in the DAQmx C code, I receive the same error as above in the test panel GUI display.


have tried the following:

- I can see the task devices and can confirm they are correct using GetTaskDevices, and GetTaskChannels. Confirmed the devices are [ correct host/deviceName, correct module ], and that the correct channels are assigned to the task nameModx/portx/linea:b

- I have tried swapping modules connecting to the host computer

- I have tried swapping modules within the chassis, and also between the two chassis

- I have tried resetting the device as well.

- I have tried swapping the chassis connection to the host computer (host -> cDAQ_a -> cDAQ_b :: host -> cDAQ_b -> cDAQ_a)

- I have tried accessing test panels to rule out an issue with my coding but have same error as above when trying to start it


Preliminary internet searches have not returned beneficial results for me so I'm throwing up a post on the forums here. Any and all help/suggestions are appreciated.

0 Kudos
Message 1 of 3

It sounds like you are missing a route


Dig out the manual and read up @ 7-3


"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 3

Thanks for your suggestion, I’ll get on it and get back to you.

0 Kudos
Message 3 of 3