Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

DAQmx/DAQmx Base firmware switch 6009

Go to solution

I have installed NI-DAQmx base v3.2 on Ubuntu 8.10.  Thanks to all previous posters for the detailed instructions!


lsdaq does not see the 6009, lsusb shows that it is connected.


I understand that I need to re-associate the 6009 to "DAQmx base" by updating the firmware.  I ran the FWUpdate that is included with 3.2 but like the lsdaq, it does not see my 6009.


I installed DAQmx v8.8 on my windows xp machine and am attempting to swap the firmware using the instructions in KB 3NE7GJMY as listed below:

NI DAQmx 7.5 - 8.5 (Preferred Method)

Switching to NI-DAQmx Base

  1. Open the Windows Device Manager:

    • Right-click on My Computer and select Properties.
    • Select the Hardware tab and click on Device Manager.

  2. Find the USB-6008 under Data Acquisition Devices.
  3. Right-click on the USB-6008 and choose Update Driver...
  4. In the popup that appears, select Install from a list or specific location and click on Next. (note: this is not the default selection)
  5. In the next window, choose Don't search. I will choose the driver to install and click on Next. (note: this is not the default selection)
  6. Select NI USB-6008 Multifunction IO and click on Next.
  7. This will put the USB-6008 into a mode for receiving NI-DAQmx Base firmware. The device should now appear in the Device Manager under NI-VISA USB Devices. If it does not show up or shows up with a yellow exclamation point, please unplug the USB cable from the device and plug it back in. This should make the device re-enumerate properly.

Steps 1-5 work great, but my options for selection in step 6 is "USB-6009" not "NI USB-6008 Multifunction IO"

I select "USB-6009" but when I hit "Next", it immediately updates the driver and states "Completing the Hardware Update Wizard".  It then notifies me that "the wizard has finished installing the software for USB-6009"  When I click "Finish", the wizard exits and I am right back where I started.  I never get the opportunity to go to step 7 above.


The Alternative Method in KB 3NE7GJMY suggests using MAX and to do the following:

"Select Tools >> NI-DAQmx Configuration >> NI-DAQmx USB Driver Selector "


When I do that, a popup appears that refers me back to KB 491FPHB9 which then points me back to KB 3NE7GJMY and again, I am right back where I started.


This was supposed to be the easy part.  All the KBs reference DAQmx v8.5 and lower.  I have 8.8.  Has something changed?


Thanks in advance,



0 Kudos
Message 1 of 5

Hi Mike,


I just went through the same rigmarole a few days ago, but with a USB-6501, which is supposed to act just like the 6009.  When I got to step 6, the window looked like the picture I attached to this message.  The upper choice is digitally signed, and is used when I want to use the hardware with DAQmx.  The bottom choice is not digitally signed, and is what I had to choose for it to work with DAQmx Base.  When you choose the latter, the hardware will change from a "Data Acquisition Device" to a "NI-VISA USB Device" in your Windows Device Manager.  If you don't have the bottom choice, I don't know what to tell you.


I hope this helps.  I also have winXP, mx8.8, and mx base 3.2.



0 Kudos
Message 2 of 5


Thanks for your reply.  You are correct, I only have the one line in my driver update menu that only allows update for the USB-6009.  That explains why I am having difficulties, but does not explain why my configuration seem to be different fromt he norm.  Are you running DAQmx and DAQmx Base on the same box?





0 Kudos
Message 3 of 5
Accepted by mamato

Hi Mike,


I just want to confirm that with Windows Xp SP3, DAQmx 8.9(latest installed version), and DAQmx Base 3.2 I was able to get a USB-6009 to change over to a DAQmxBase device.  I was able to re-associate the driver so that the device would show in device manager as NI USB-6009 Multifunction IO.  I simply followed the directions in KB#3NE7GJMY.  My only recomendations at this present time would be to check your version numbers on both DAQmx and DAQmx Base.  It does sound like DAQmx base was not installed properly as we are not seeing the second driver in the device manager.  I would suggest re-installing DAQmx Base (note you do not need to un-install DAQmx to do this).   Let's try that and see if we can get the second driver to show up
Charley Dahan

Global Account Manager
0 Kudos
Message 4 of 5


Thanks for the response.  I reinstalled DAQmx Base 3.2 on the XP machine and now am able to see the second driver and re-associate the 6009 with DAQmx Base.  I ran FWUpdate on the XP box, then disconnected and moved the device back to my Linux box.  It still does not show up when I run lsdaq or FWUpdate on the linux box.  I'll check into that today.


Thanks again for the support.




0 Kudos
Message 5 of 5