Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ digitizer undefined error troubleshooting help

Solved!
Go to solution

Hi, I have a question about a PCI-5152 DAQ digitizer from NI. I am having a problem with the initialization stage block of the drivers from the digitizer. I receive this error code -1073807343 from the initializer block. (Error code is undefined…)

The data files have nothing written in them so basically the card is not functioning properly with the LabVIEW program.

Also, the I made sure digitizer is hooked up to the proper input on mother board. (Therefore, not a connection/ obvious hardware issue). Do you have any ideas for a solution or troubleshooting?


Also, one more thing. The LabVIEW code was functioning about 3-4 months ago. Then, I left for summer. When I returned, I was having this issue. Apparently, no one in my lab even turned on the computer in this time. The only change that was made was the removal of a second DAQ card (separate from mine) in the same computer. It was removed (properly) and placed into another computer.Block of CodeBlock of Code

 

Description on initialize driverDescription on initialize driver

 

0 Kudos
Message 1 of 3
(2,258 Views)
Solution
Accepted by topic author JesseTrueLab

Hello,

 

I ran across this KB which might be of some assistance in narrowing down what the issue is.

Error -1074118655 (0xBFFA4001), -1073807343 (0xBFFF0011) or -1074118644 (0xBFFA400C) Occurs When Add...

 

Not sure how this would've changed if the computer hasn't been on for a few months. If the other card is lying around and easy to take out, does this VI function when you add it back to your computer?

 

-Ryan M

0 Kudos
Message 2 of 3
(2,204 Views)

rsmayer,

 

Thank you for the help! your link helped me trouble shoot the program aka (find a definition for the undefined error) 

 

It was a very basic mistake. In the LabVIEW front panel, when I was declaring the device. There was a device 1 and device 2 option. It turned out I was declaring the wrong device. Therefore it would be looking for the other DAQ card that was removed which caused a power error in the initialization. 

 

Thanks again for your help,

Jesse

0 Kudos
Message 3 of 3
(2,188 Views)