Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ Assistant does not see physical channel

I'm using Labview 7.1.1 and DAQ 7.5 to get a voltage reading from a NI cRIO9215.  When running the DAQ assistant, I can select the analog input and then voltage, but on the next screen it does not give me any choices for the physical channel even though the instrument hooked to the DAQ is turned on.  MAX can see the DAQ hardware, and I can run a VISA session, but I don't know how to get LabView to talk with my instrument. Any suggestions are welcome.
Thanks,
Bash
0 Kudos
Message 1 of 5
(5,276 Views)

Hello Bash,

To  check your cRIO-9215 in MAX to be sure that it is working correctly, you will need to look for it in the configuration tree under Devices and Interfaces >> DAQmx Devices rather than opening a VISA session to the device since NI-DAQmx is the driver that you will use to control the device.  If you do not see your device listed under NI-DAQmx devices, it may be compatible with NI-DAQmx Base instead.  You can check this by going to Start >> Programs >> National Instruments >> NI-DAQmx Base >> List Devices.  If you have this program and it finds the 9215 as a DAQmx Base device, then it is only compatible with this driver and you cannot use the DAQ Assistant with it.  Please see this knowledgebase which explains the differences between the 9215 which is compatible with NI-DAQmx Base and the 9215A which is compatible with NI-DAQmx. 

Please post back if this does not clear up the confusion or if your 9215 does show up under DAQmx Devices in MAX, but not in the DAQ Assistant. 

Thanks,

Laura

0 Kudos
Message 2 of 5
(5,260 Views)
Thank you for your help.  I do see my device under the configuration tree as well.  I went ahead and uninstalled the DAQmx 7.5 and am using the DAQmx base 1.4 now.  I can still see my USB device in MAX.  I also see my device in the DAQmx Base configuration utility.  I have created tasks in this configuration utility.  However, when I click on browse for the I/O for the physical channel in LabView nothing is listed.  How can I get Labview itself to see my device and use it for data aquisition?
Thanks for your support,
 
Bash
0 Kudos
Message 3 of 5
(5,253 Views)

Hi Bash,

I am glad that you were able to get your USB 9215 configured. Since you are using DAQmx Base, you will need to manually type in the name of the tasks in LabVIEW after you configure them in the NI DAQmx Base Task Configuration Utility. Here is a knowledgebase with additional information about this: NI-DAQmx Base Tasks and Physical Channels Are Not Listed in the LabVIEW Task and Channel Constants a....

Regards,

Hal L.

0 Kudos
Message 4 of 5
(5,234 Views)

Hi, I am having a similar issue but the link you have posted is now dead. I am using a PCIE 1816 Advantech mulitfunction card on Labview on windows 8.1.

I am trying to read the clock of my Card into the Labview program so that i can run the timed loop at a clock rate faster than 1 KHz. 

Any suggestions are welcome.

TIA

0 Kudos
Message 5 of 5
(2,585 Views)