Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot reserve chassis 9188 upgrade

Hello,

 

I have the following issue with the chassis 9188:

 

I use static IP for 9188 and it worked well. After a couple of month, when maybe I made some upgrades to my PC, I tried to reserve the chassis and didn't worked. Then I used network browser to find the chassis and I did made a firmware upgrade from 1.1 to the actual version: 1.5.1f0. The upgrade didn't changed the behavior in NI-MAX : I can see the chassis connected, but when I try to reset it I get the error message: -201401 that say I cannot reset the chassis. After upgrade I notice that in Network browser I see only the general settings, nevertheless I try to change the pages by clicking on the right icons. I tried to flash again but I cannot access the menu where the file can be uploaded.

Like I already said, the chassis is reachable, ping is working, I can reboot it from NI-MAX, and I can see general settings from NI-network browser, that is all I can do on this chassis.

 

Thank you for your help/tips.

 

Daniel

0 Kudos
Message 1 of 9
(4,286 Views)

I forget to add:

 

I use Win7 64bit

DAQmx 9.7.5

NI MAX 5.5.0.f0

 

 

It seems to be something wrong with my system, because I tried to reserve it from another PC and it worked out. On the other system was a lower DAQmx version, 9.6.2

 

 

0 Kudos
Message 2 of 9
(4,277 Views)

Hi Daniel,

 

Just to re-cap, where you able to add the 9188 to MAX? The error that you get; -201401 is related to not being able to add device to MAX. If this is so, there is discussion forum which points out that you may need to reset the network adapter on your system. You can view the link below for more detail on the discussion forum:

 

http://forums.ni.com/t5/Measure/Adding-a-Device-201401-Make-sure-device-is-connected/m-p/2630087

 

Do let me know if my assumption is correct. Thank you.

 

Regards,

Alan

Applications Engineer | National Instruments
Singapore (65) 6226 5886 | Malaysia (60) 3 7948 2000 | Thailand (66) 2 298 4800
Philippines (63) 2 659 1722 | Vietnam (84) 28 3911 3150 | Indonesia (62) 21 2783 2355
0 Kudos
Message 3 of 9
(4,267 Views)

Hi Alan,

 

I checked the network tab, there are all settings as expected. I attached a screenshot, I have the german version, I hope you handle with messages, as they are standard.

Like I said, this issue is only on my computer, I tested from another PC and he was able to acces / reserve the chassis.

I will try to reinstall/upgrade DAQmx. Actual version on my system is 9.7.5f1

 

Thank you, I will keep you in touch...

 

Daniel

 

error add chassis.png

0 Kudos
Message 4 of 9
(4,264 Views)

I reinstalled DAQmx 9.7.5 and no effect.

Now I heard that another colleague has the same problem with chassis: He cannot reserve it, despite the chassis is listed in  NI MAX, and has an IP address.

0 Kudos
Message 5 of 9
(4,255 Views)

I installed DAQmx 9.6.0 same problem.

0 Kudos
Message 6 of 9
(4,251 Views)

Hi Daniel,

 

Probably we can try to look at some troubleshooting steps to confirm that this problem is PC dependant. You can refer to the link below

 

http://digital.ni.com/public.nsf/allkb/E67B4E4749F378FF862577270059BD4B?OpenDocument 

 

Since you have manage to detect the hardware on MAX, we can skip some of the steps shown in the link. I have summarized some of the steps that you can take.

 

1. Check the states of all LEDs on the hardware. Let me know what are the states after the hardware is active for a few minutes.

 

2. Set the IPv4 settings on your computer to automatic.

 

3. Disable any firewall on your PC.

 

4. Disable any virtual machine network adaptors such as VMware.

 

Do try these steps out and we can progress from there. Thank you.

 

 

Applications Engineer | National Instruments
Singapore (65) 6226 5886 | Malaysia (60) 3 7948 2000 | Thailand (66) 2 298 4800
Philippines (63) 2 659 1722 | Vietnam (84) 28 3911 3150 | Indonesia (62) 21 2783 2355
Message 7 of 9
(4,209 Views)

Hi Alan,

 

I did contact our local NI support, and we tried one hour all kind of possible settings without success. During my further researches I noticed that all our win7 PC, that already worked with this kind chassis, doesn't worked anymore. WinXP PC was working all the time. Then I went to our network admin, and we checked if there are port-filtering for the ports used by chassis for communication. He said there is no restriction in our network, then he tried to go remote on a couple of win7 PC and see the failure (-201401). After reviewing firewall settings on the PC, he could reserve the chassis, and then it worked.

I cannot say now if the local firewall settings was the problem or it was a domain problem that issued only in win7 PC.

We suspect that maybe installing the NI software using a local admin account, and after that logging into domain, it could restrict the traffic for this application...

The fact is that now all win7 PC are now able to reserve the chassis.

 

The problem now is that we don't really know what made win7 not being able to reserve the chassis and further, what did solve that issue. For now the most of chassis are in developments projects, but when we will use them in production, there is no way to fall out for a couple of days ...

 

Thank you for support,

 

Daniel

0 Kudos
Message 8 of 9
(4,206 Views)

Hi ,

 

 

I have very similar problem of 9188 reserve issue. My project using 9181 and 2 units x 9188. 

All the firmware are of 1.1

There is no problem with 9181 and the 1st 9188 during i build my application. On the 2nd unit of 9188 everything look fine as expected but during i run my labview application to burn in reliablity noticed of the 2nd 9188 causing my labview program hang.. It is very intermittantly. Sometime run for 3 days no issue. When encountered problem in my labview i go in check NI MAX the last 9188 has error and disconnect.ed..Sometime chassis 9188 lost connection or sometime the C module i used 9425 has error.

I have press reset 2nd unit of 9188 and therafter no hang issued occured but i believe there still have intermittance disconnection problem as i have log my application with .txt file... in my log there is time and date.. noticed of unwanted data inside..

My labview pc NI MAX is 14.5 . Window 7 32 bit.

During problem i have to reset 9188 through NI MAX and have to rerun my labview application.

 

I also noticed some wired thing in the 2nd unit of 9188.. My labview pc have make sure reserve 1 x 9181 and 2 x 9188. But in my another pc which has NI Max old version of 4.5 in the Device and Interface tag >> Network device i see the 9181 and 1x unit of 9188 has seen reserved but the problem unit has seen not reserved and if i not wrong i can reserved from that pc and used it. So i suspect this causing my labview pc auto disconnection issue of the 2nd unit 9188.

 

I have set my device with static configuration. Under subnet mask 255.255.252. IP are unit..

I have trouble shoot my problem hardware by the following..

- Swapped another network port. Disconnection still occured

- Swapped network cable. Problem still occured.

- Make sure the ip address i set to that problem 9188 has no one using this ip address and i have config. In the NI Max i saw it sometime auto disconnect still.

- Upgrade 9188 to latest firmware 1.5 . (Under monitoring)

- I have open another brand new 9188 and test. Believe would be same problem of auto disconnection issue as after i config.. NI Max i have reserved 9181 and 2 x 9188 . I go in another NI MAX pc and the 3rd unit of 9188 is seems as not reserved by any pc and i still can add in.

 

If here anyone here can help or any suggession is very much appreciated.

 

Thanks and Regards,

Brian

 

 

0 Kudos
Message 9 of 9
(2,849 Views)