Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

CVI 8 has unknown error while building distribution kit.

I installed the CVI 8 upgrade I recieved in the mail. Now it gives an error while trying to make a distribution kit. I noticed the new distribution manager and created a new entry, leaving everything at the defaults. I chose build and it says "An unknown error occured." I have played with the settings for an hour or so and on occation it will give a different error: "Internal API function call order violation." Nothing I have tried has allowed me to generate a distribution kit. The only thing I can think of that might be related is that I uninstalled CVI 7.1 after installing 8.0. I am surprised that this was not automatic. Why would i need 2 versions of labwindows on a machine at once?
0 Kudos
Message 1 of 6
Hello Vahid,

I'm sorry to hear you are receiving errors when building your distribution kit.  First of all, if you try to build one of the shipping examples into a distribution kit, do you get the same error?  Are you currently trying to convert a 7.1 distribution kit into an 8.0 distribution kit?  Also, what drivers, if any, are you adding into your application?  Also, if you could give me some more information on a list of things you did to reproduce the problem, it would be helpful to reproduce it on my end.

Regarding your second questions, one particular reason why a customer would want both versions of CVI on their machine might be if they are developing an application that needs to run on a CVI 8.0 unsupported operating system.  CVI 8.0 and the 8.0 runtime engine are only supported on Windows 2000 and Windows XP, so in order to develop your application for another operating system, you would need one of the other versions of CVI and create a distribution kit in that version.  Note that CVI's list of currently supported operating systems closely follows Microsoft's currently supported operating systems.

Hope that helps, and I look forward to your response.

Wendy L
LabWindows/CVI Developer Newsletter
0 Kudos
Message 2 of 6


      I tried building dist kits for a couple of the shipping examples. The first one was just a basic user interface demonstration and it built successfully. The second was an app to read the digital values from a DAQmx device and this one failed with the same error as I was getting before. In one of my applications I am using DAQmx with a USB-6501. This app I have build entirely in CVI8. It fails for the same error. Another one of my applications uses a DAQ PCI card (traditional API) and was originally built in CVI 6. It also fails for the same error. Other applications that I created with CVI 7 build dist kits just fine, but none of them use DAQ hardware. It seems the common theme is that any app that requires DAQ hardware will not build a dist kit. I will try reinstalling the DAQ drivers and see what happens.

0 Kudos
Message 3 of 6
I uninstalled and reinstalled the DAQmx driver but it did not help. The same error occurs. I will try uninstalling all NI software from my computer and then reinstalling CVI8.
0 Kudos
Message 4 of 6
Hello vahid,

This is likely a problem that occurs when newer, deployable versions of installed drivers (ie DAQmx) have dependencies on other support drivers that have not been upgraded and are not deployable.  Try following the steps in this thread and see if they solve your problem.  If not, please use those instructions to create a debug log and post it back to this thread.


Mert A.
National Instruments
0 Kudos
Message 5 of 6
I reinstalled CVI8 and the DAQmx drivers and now building a dist kit with DAQmx works fine. There must have been an old driver caught in there somewhere. Thank you for your assistance.
0 Kudos
Message 6 of 6