Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

CJC problems with SCXI 1102 + SCXI 1303

Go to solution

Well I'm using NI-DAQmx 8.0.0f0 (with MAX , there's nothing to update 😕

Any idea would be greatly appreciated...

Message Edité par Fabrice K. le 01-02-2006 04:00 PM

0 Kudos
Message 11 of 14

hi Fabrice,

A "software problem" is not very likely.( wrong thermocouple parameter can be a common reason, very rarely a software corruption will occur)

could you swap the DAQ card that is multiplexing the scxi modules??

Could you check if any special grounding considerations are taken on the Test bench setup?

Message 12 of 14

Hi Dev,

the "working" test bench (from which I took the "working" spare modules) uses standard K-type thermocouples with no specific grounding considerations...

As for my brand-new system under test, I simply wired a thermocouple to an input channel and configured that channel in MAX. I'm very puzzled about what parameter could be wrong with such a standard setting and so few parameters that can be configured in MAX 😕

Again, I would like to remind you the offset problem only occurs when using CJC calculated with built-in sensor in SCXI-1303 terminal block. Using a non-calculated parameter (fixed value) or another terminal block with another CJ measurement technology (SCXI-1300) solves the problem, that's why I was thinking about a software (driver) bug, especially with a quite new piece of hardware (USB SCXI-1600 DAQ modules are available since no longer than one year, as far as I know).

And to answer your question I'm sorry to answer no : I don't have any other SCXI-1600 DAQ card, thus I can't swap it with another one 😞


Message Edité par Fabrice K. le 01-03-2006 10:26 AM

0 Kudos
Message 13 of 14
Accepted by topic author Fabrice K.

Okay problem is (almost) solved now...

In my SCXI-1000 chassis, beside the SCXI-1600 (DAQ) and the SCXI-1102 (Thermocouple/Voltage) modules, I also had 2 other brand new modules : one SCXI-1102C and one SCXI-1520.

I tried to unplug them and then... my thermocouple measurement worked fine !

The problem was caused by the SCXI-1102C module : as soon as I plug it in (whatever slot I put it in) , measurements are erroneous on my SCXI-1102 module if I use built-in CJC and a SCXI-1303 terminal block (in any other configuration, measurements seem to be okay). Strange, uh ? But at least for now I can use the system for my thermocouple measurments with internal CJC and virtualy no noise. 🙂


Then I checked if I could get a measurement from that strange SCXI-1102C module... and it looks like it sends only random measurements, whetever slot I put it in (alone or together with other modules) and whatever signal I connect to it. I guess there's a hardware problem on this module, perturbating the multiplexed analog signal on the SCXI backplane.

I will later check that module on another (PXI + SCXI) chassis to be really sure it is defect and send it back to NI for repair or replacement.

Message Edité par Fabrice K. le 01-03-2006 04:19 PM

Message 14 of 14