Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

6211 phase angle

Solved!
Go to solution

Hello,

 

I wish to measure a constant phase angle between two signals (the same freqency) applied to two different input analog channels. I would be greatfull if someone explain the algorithm and give the code in LabWindows or LabView.

 

Second question: for what there is a number of scan list entries described in specification of the 621x devices? Is this possible to create scan list for that devices?

 

0 Kudos
Message 1 of 10
(3,336 Views)
Solution
Accepted by kamkon

Hi kamkon,

 

I know a method to measure the phase angle between two signals, but it's necessary to take a signal as reference and a difference between signals. This method is useful to measure a small phase angle.

I don't know if it can help you.

Ariel

0 Kudos
Message 2 of 10
(3,331 Views)

I see this marked as the solution but I dont see it.

 

I have a reference signal and an output signal and I need to find the phase angle.

 

In other instrument i know the phase angle is 8.69  but not getting the same results in Labview.

 

I'm also using NI-6211

 

thanks

JCollado
0 Kudos
Message 3 of 10
(3,034 Views)

Hi JCollado!

 

So if I understand your problem, you have two signals, and you want to measure the phase angle between them, with two AI of the NI 6211 ?

 

As I see this topic is quite old, and the solution isn't avaliable, maybe there was a private message between the other two guys...

 

I would like to ask you to open a new topic, and describe your problem there. I think it will be better to discuss the solution there. 

 

Thanks, and best regards,

CLA, CLED
0 Kudos
Message 4 of 10
(3,016 Views)

Thank you.

 

I will do that.

 

JCollado
0 Kudos
Message 5 of 10
(3,007 Views)

Hi, J Collado,

 

I saw your post. Sorry by delay my post.

I know how to measure the phase angle between two signals, but is needed to get both a signal as reference and a signal difference or "DELTA".
Let me know if this way is possible for solve your problem.

I going to try to send a schematic draw.

 

Ariel

0 Kudos
Message 6 of 10
(3,004 Views)

Hello

 

I have this VI which is giving me the Phase angle and it appears to be working except the actual phase angle  in my external instrument is 8.67 and the phase angle read in my Labview app is about 23.8 degrees.

 

I assume this is due to the 6211 not being a simultaneous reading for all channels. 

 

Or do you see any other problem with the VI?

 

Maybe you can upload the SubVi that is working for you to compare results?

 

thanks

JCollado
0 Kudos
Message 7 of 10
(2,998 Views)

JCollado wrote:

I assume this is due to the 6211 not being a simultaneous reading for all channels. 



From NI USB-621x User Manual:

Each USB-621xdevice has one analog-to-digital converter
(ADC). The multiplexers (mux) route one AI channel at a time to the
ADC through the NI-PGIA.


 

I think you are right, the reason of the different phase angle is, that tha NI 6211 has multiplexed AI channels, so for such kind of measurements, you need a simultaneous sampling device, like these: http://sine.ni.com/nips/cds/view/p/lang/en/nid/209151

 

Best regards,

CLA, CLED
Message 8 of 10
(2,978 Views)

Thanks fo rthe confirmation  BalazsNagy.

 

I have compensated for teh delay in the card and any time I get a different phase angle I am also getting the same reading.

 

Menaing I used the known phase and subtracted the difference from my labview reading. It may be off by up to .1 degrees but that will be ok for this project.

 

In the future I will have to buy the silmultaneous reading card.

 

I have posted the solution to " how to read in-phase voltage" in my other link:

http://forums.ni.com/t5/LabVIEW/HOW-DO-I-READ-VOLTAGE-IN-PHASE/m-p/2127274#M689940

 

Thank you.

JCollado
0 Kudos
Message 9 of 10
(2,973 Views)

Hi all,

 

I put this thread back to life since I have the same kind of problem. The only difference is that I want to measure the phase lag between a signal I generate on an analog output and the signal I get from an analog input.

 

I'm using a USB-6212 and I'm testing my program by wiring directly the AO to the AI. In that case, I expect to measure a zero phase lag. It is not the case.

 

More suprisingly, whatever I do in my test VI (very similar to the example Multi-Function-Sync AI-AO.vi), the phase lag (measured from Extract Single Tone Information VI) between my two signals seems to take only two values: -17.468 and 68.931, the first one hapenning more often than the other. Could you tell me why ? Is there a way to get a proper phase lag measurement between an AI and an AO ?

 

Thanks a lot for your help !

JB

____________________
JB
0 Kudos
Message 10 of 10
(2,839 Views)