Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

4113 Board Not recognized by TestStand

I have a PXI system with 7 PXI peripheral cards in which two of them are 4113 power supplies.  This is an old setup we are trying to repair.  I have ran MAX program and verified that all of the devices are present and self-tests pass.  The Windows Device Manager shows all of the devices.  When I run my scripts in Test Stand, I get the following error


4113A is not part of your configuration.


Any idea what might be causing it not to find the physical device?

0 Kudos
Message 1 of 8

Additional information about your teststand sequence and the way you use these instrument would be helpful.


If you can use something from NI MAX and definitely you could access them from LV and TS as long as you have the right code implemented and use the right alias to create a session.

Semiconductor Validation & Production Test
Soliton Technologies
0 Kudos
Message 2 of 8

We are using the system to perform automated test of printed circuit board assemblies in a pin tester.  We have some digital, analog and high voltage signals.  We are utilizing two 4113 power supply boards, a Multifunction DAQ, Industrial DIO and two Relay boards.  These are the peripheral boards.  Not sure what the main/processor board is but it doesn't have any IO except for one connector which connects directly to the test PC with NI cable and a PCIe interface card.  I don't know much about the test computer's software architecture except we are using TestStand/LabView.  As stated previously, all of the peripheral cards show as present when we run the NI MAX utility but when we run the TestStand is says it is not part of the configuration

0 Kudos
Message 3 of 8

Usually, TestStand and LabVIEW applications work based on the Aliases of devices, which can be set in NI MAX. In my case, the Alias of the PXI-6251 is "PXI1Slot2" (it's yellow because it's a simulated device, don't worry about that, yours will look different).



So anywhere that I want to use that PXI device, I need to plug in the name "PXI1Slot2". 


I think what the other person in this thread was suggesting was to compare the Alias of this device with the Alias that the TestStand sequence is expecting. Do you know if there is some kind of configuration file, or some location in the sequence where you have to specify the name of your device? It has to match exactly with what's in NI MAX, so if your application is expecting the alias to be "4113A" then you may have to rename the device in NI MAX to match that name.


If you've got two 4113s, then you should be careful to make sure that you don't swap the names, because that could cause problems depending on what they're actually wired to.


Nathan Murphy
Certified LabVIEW Architect
Hiring CLD/CLA in Southern California
DM for details
Message 4 of 8

Yes, I was able to get the aliases from the TestStand failures and changes them in the MAX configuration.  I got my LabView script to pass the HW present tests now but I have a new one.  I get message


Switch Executive failed to initialize virtual device "SwitchRelays"  Error Code -29002


Do I need to do something in MAX to recreate the virtual device?

0 Kudos
Message 5 of 8

Yeah, seems like you're not out of the woods yet. You should see a section in MAX for Switch Executive devices. Switch Executive is a piece of software that aggregates switch modules to make named switch routes, etc. You configure specific routes in MAX and give them certain names so that you can use them in your LabVIEW application. So for example, if you have a matrix module and want to make a route from row 1 to columns 3, 5, and 8, you can save that route as a single name and then within LabVIEW just say "open route A" or "close route A" and it will open/close the corresponding switches.


I say this because a Switch Executive virtual device will probably need to have routes associated with it, too. It wouldn't do you any good to just create the virtual device, you need to know what routes that virtual device has associated with it. 


You said this was from a PC you were trying to repair, so hopefully you have a backup of the old configuration? That's going to be your best bet. Or maybe if you have any of this documented anywhere, you can use it to restore the system back to the correct configuration.


Otherwise, you'll probably have to recreate the virtual device by reverse engineering the code and your hardware setup to try and figure out the names of all the routes and the connections required to make the system operate the way you expect. 

Nathan Murphy
Certified LabVIEW Architect
Hiring CLD/CLA in Southern California
DM for details
0 Kudos
Message 6 of 8



I found some .nce Configuration files and attempted to import them with the Switch Executive option to Import.  I looks like it was going to do something for the missing SwitchRelays virtual device.  When it imported it encountered an error and failed to import.  It looks there is a syntax error somewhere but I have no idea how I can correct it.  I have provided part of the report below.


NI Switch Executive 3.6:
Note: Changing the port requires a restart of the RIO server or a reboot on the destination system.
Note: Select View>>Refresh or press F5 in MAX to see any settings that have changed.
Fatal Error: SwitchRelays failed to import. An error occurred while attempting to read from the file.
Invalid Endpoint1 "A35_VDD_10V " for Route Name "A35_VDD_10V-to-4113B1_6"

The channel specification string contains invalid characters or could not be understood. No match could be found for the given channel alias name or IVI channel name. Channel:A35_VDD_10V

*** Import FAILED ***
NI Switch Executive 3.6: error code 0xffff8e9


I tried attaching the full report but the website would not allow it.  There appears to be a undesired " " after 10V

0 Kudos
Message 7 of 8

Seems like you're heading the right direction, but I think this is out of my league now... Maybe try importing to other PCs to see if those have similar issues? Maybe try other .nce files? Do you have another PC with the same setup that you can re-export from? I don't have a lot of experience debugging MAX configuration import errors, so I'm not sure where else to go from here.

Nathan Murphy
Certified LabVIEW Architect
Hiring CLD/CLA in Southern California
DM for details
0 Kudos
Message 8 of 8