Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

-224606 Internal Software Error using 2 USB6001 cards

Highlighted

-224606 Internal Software Error using 2 USB6001 cards

I have an application where I am using 2 of the USB6001 OEM daq cards that are read in a loop like this:

Dual USB6001 Cards.jpg

 

The tasks that are passed in are created outside of the read loop - so they only get created once.  I ran my system for many hours with no problems and then got the following error message:

DAQmx Stop Task.vi:3590009<append> - <B>Task Name: </B>Analog Input Low

 

I can tell from the 3590009 that the bottom stop task is where the error occurred - the 'Analog Input Low' is the channel name.  So the top read had to have occurred without error because it's error would have been selected when the top and bottom errors get merged.

 

In reading through what info I could find one of the suggestions to fix this error is to reinstall the daqmx drivers.  So I uninstalled the labview runtime engine and the daqmx drivers and then reinstalled them (Labview 2014 64 bit with daqmx v14.2.0) - the system the cards are on was powered up through all of this.  After restarting the computer (windows 7) and launching my application again I immediately got the same error, from the exact same VI, as soon as the analog input loop started.  So once again one of the USB6001's was working fine and the other wasn't.  I restarted my application multiple times with the exact same result.  Then I powered down the hardware, restarted the hardware to reinitialize the USB6001's and after this everything worked just fine. 

 

This leaves me with a few questions:

Is this a software or a hardware issue?  If it was software/driver related why did this only happen with one of the 6001's and not the other.  Why did the problem only go away after doing a power cycle of the hardware? 

 

I got the exact same error on another system sometime back.  I tried installing the latest version of daqmx on that system but I would still occasionally get the error.  On that system I ended up removing all NI software and reinstalling the labview 2014 64 bit runtime engine and daqmx v14.2.0 and so far I haven't seen the error again on that system.

0 Kudos
Message 1 of 4
(464 Views)

Re: -224606 Internal Software Error using 2 USB6001 cards

Hi dloasn, is this error reproducible if you only use one of the USB 6001 cards?

"I tried installing the latest version of daqmx on that system but I would still occasionally get the error. "

You mean DAQmx 16.0 with LabVIEW 16?

 

Very general troubleshooting steps:

http://digital.ni.com/public.nsf/allkb/1B7C591595D03F82862574120068AB55

One last thought that comes to my mind. Are the two cards in different enclosures? If it's a hardware issue, it may related with temperature issues and that could be the unnoticed difference between the two devices.

0 Kudos
Message 2 of 4
(401 Views)

Re: -224606 Internal Software Error using 2 USB6001 cards

Both of these cards are on the same circuit board so they are in the same environment.  I can't really test things with just one card but  I've had this issue on several different systems and it is very sporadic.  I have had instances when  the issue occurred on the other daq card (the acquisition on top in the image).  The  systems can run for many days with no problems and some systems haven't had the problem at all. 

When I used the latest version DAQmx it was v16.0 but with the same executable that was compiled with the 64 bit version of Labview 2014.

 

I've seen the article you linked to - I think this is the one that led me to updating to the latest version of DAQmx. 

 

I'll also add that our older systems used two of the USB6008 daq cards and I never saw this error on any of those systems running essentially the same software.

 

I would really like to know if this is a hardware or software error.  Given what I've seen so far I would say it seems more like something with the 6001 card as opposed to something with labview or DAQmx.

0 Kudos
Message 3 of 4
(398 Views)

Re: -224606 Internal Software Error using 2 USB6001 cards


dsloan wrote:

 

I'll also add that our older systems used two of the USB6008 daq cards and I never saw this error on any of those systems running essentially the same software.

 

I would really like to know if this is a hardware or software error.  Given what I've seen so far I would say it seems more like something with the 6001 card as opposed to something with labview or DAQmx.


The error relates to an internal (5 second, as you've noticed) timeout. The USB-6008/09 and USB-6000/01/02/03 are architecturally very different (and in fact use a different driver), so I'm not surprised that you're seeing a difference in behavior there. Given that this seems to keep popping up (e.g, this thread and also this thread from the same OP) I've gone ahead and filed CAR 635096 to the appropriate team for further investigation.

——
Brandon Streiff
ni.com/virtualbench · ni.com/daq
0 Kudos
Message 4 of 4
(387 Views)