Motion Control and Motor Drives

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI-7334 and UMI-7774

I am trying to setup a motion system using a PXI-7334 4 axis stepper controller via UMI-7774 to control some (very) expensive vacuum motors connected to a series of Phytron ZSO Mini power drive amplifiers. Before connecting up the Phytron parts, we thought we'd just test the NI parts to ensure we are outputing the proper signals so that we do not create any potential mishandling/damage to these very expensive motors.

So far, we're not able to get very, er, far, with this test setup. For one thing, regardless of the limit switches jumper setting on the UMI, the limit switches are always triggered under MAX. At least when the UMI is powered up with two separate power supplies for power isolation. In trying to determine if it is even working, we wanted to hook up some of the limited switches to just get some interaction to confirm that the UMI is working. How should we close the circuit on each of the home, forward and reverse switches? Pin 10-12 are labled home, forward, and reverse, but where is the common line (if it is indeed common) that they need to be connected to in order to complete the circuit?

This is of course, assuming that limit switches are even necessary in order to conduct some simple step tests in order to measure pulses coming out of the UMI. I've gone as far as disabling all of the limited switches in the configuration setion of Max and still, I am not able to get any movements out of MAX.

This is on an NI integrated PXI chassis which we purchased with a P4 2.2GHz embedded controller.

Thank you in advance for you considerations,

Dominic
0 Kudos
Message 1 of 5
(2,006 Views)
If you are using separate power supplies for the UMI box make sure that GND pf these supplies is properly connected to the GND terminals of the UMI box, and that GND of the UMI box is connected to GND of the 7344 board. Usually you don't have to care for this since the standard cables provide connection between the UMI box and the GND pins of the 7344 connector.

Also, the GND (or digital GND - DGND) pin/terminal is the reference for the limit switches. When connecting limit switches make sure that there is a connection from the GND terminals of the UMI box to the switches. I think this is clearly shown in the diagram on p.8 of the UMI manual (limit switches terminal block). The switches can be either active high or active low polarity, this can be set with MAX and is necessary for proper detection.

Limit switches are not necessary to get step pulses but you have to make sure that MAX does not indicate any activated limit switches - in this case, of course, the 7344 board does not send any step pulses.
0 Kudos
Message 2 of 5
(1,998 Views)
Thank you for the reply, I will definitely double check on the GND pins. I, too, thought that the limit switches are not necessary in order to send pulses because I have been successful before as well that I have tried disabling limit switches in software already. However, that might be the gist of my problem. Regardless of my settings so far, (active high, or low on the UMI), the limit switch indicators will not alter its state in MAX. The LED on the UMI itself will go on and off depending on the high/low settings. But the Max indicators never change and is always red (forward/reverse and home), hence the idea of actually hooking up switches to validate connectivity. So that is probably the root of my problem and the reason why its not sending pulses. Do you have any ideas on how to trouble shoot that problem?
0 Kudos
Message 3 of 5
(1,988 Views)
Limit switches do not need to be hooked up to output stepper pulses, they just need to be not activated. If the red light is on in MAX for any of the limit switches, the board will not output any pulses beacuse it thinks it against a hardware limit switch.

The switches on the UMI ONLY change the active high or active low polarity of the LEDs on the UMI. These switches do not control what signals are sent back to the motion control board. Again, the switches only control the LEDS.

To get your system to at least output pulses, change the polarity of the limit switches in MAX under "Axis Setting" then re-initialize your board. This should make the limit switch lights go off in MAX under 1-D interactive so the board will output pulses when you command moves.

Nicholas C
National Instruments
Applications Engineering
Message 4 of 5
(1,967 Views)
Thanks, Nick, that did the trick. Of course, I saw this message only after we have already hooked up the switches and were able to get what we needed. Still, it would have been much easier solution to do in software for future reference. Good thing we wanted the limit switches anyway.
0 Kudos
Message 5 of 5
(1,964 Views)