Motion Control and Motor Drives

cancel
Showing results for 
Search instead for 
Did you mean: 

P7000 Tools not jogging 3rd party motor

Solved!
Go to solution
Highlighted

I am trying to control a 3rd party stepper motor with P7000Tools but I can not get it to jog the motor.

 

Setup:

Pacific Scientific P70530 drive

MicroKinetics 23HT175 stepper motor (http://www.microkinetics.com/stepper_motors/23ht175.htm)

National Instruments 780099-01Serial Programming Cable for P70530 & P70360 Stepper Drives

tabletop variable power supply (at 30VDC and max amperage)

 

P7000Tools correctly finds the drive and I have the custom motor setup as:

 

ss.PNG

 

 

If I "Send All" to the motor and them Probe it, the motor makes some noises at different frequencies. I also see the power supply incrementally increase in supply amerage. P7000Tools then tells me that the motor has successfully been probed. However, when I then try to jog the motor, nothing happens. I also notice that the motor gets very hot. Its at this point that I shut off the power supply. Any help would be greatly appreciated.

 

thanks,

jason

0 Kudos
Message 1 of 7
(4,614 Views)
Highlighted

Hi Jason,

 

After reading this, the first thing that came to mind was that the wires must be incorrectly connected from the drive to the motor.  You may want to double-check the manual for the stepper motor and verify that you have everything in the correct configuration.  Also, make sure the motor and drive are grounded properly. And finally, there are several dip switches on the motor driver, and it's possible that those are set incorrectly for the stepper motor configuration.

0 Kudos
Message 2 of 7
(4,601 Views)
Highlighted

Rory,

Its a 4 wire (A, Abar, B, Bbar) stepper motor. I have the wires correctly plugged into the drive. The drive is grounded through the ground terminal on the power supply. The motor does not have a ground.

 

Regarding the DIP switches, I was under the impression that if the drive had an internal (via P700Tools) configuration, then it ignored the DIP switches. So, do the DIP switch settings need to match the P7000Tools settings?

0 Kudos
Message 3 of 7
(4,591 Views)
Highlighted

Actually, in all but one case the DIP switches will override the software settings, not the other way around.  After reading in Chapter 3 of the P70530 manual (http://www.ni.com/pdf/manuals/P7000DC_Revision_B.pdf) it looks like the switches will need to be set all in the 0/off positions in order to use software configuration settings. Can you verify this?

0 Kudos
Message 4 of 7
(4,568 Views)
Highlighted

Rory,

I have all of the DIP switches in the 0/Off position. Is "tooth count" the same as steps/rev?

0 Kudos
Message 5 of 7
(4,564 Views)
Highlighted

tir38,

I found the following article and copied the text below.  The second paragraph explains tooth count, and here's the link to the original: http://zone.ni.com/devzone/cda/tut/p/id/10638

 

Danaher Drives (P70530 and P70360)

Danaher refer to microstepping as step resolution. The step resolution can be configured through one of two methods. One is through the DIP switches on the side of the drives as shown in the P7000 Series Stepper Drives Getting Started manual on page 9. The other is through the Danaher P7000 Tools, a software interface to configure the hardware.

 

When configuring the drive using the P7000 Tools, verify that the Tooth Count is correct. This will be located under Stepper Motor»Properties. The tooth count is one fourth of the number of steps per revolution with no microstepping. If this number is not correct it can be changed in the Motor File Editor. Set the desired step resolution under Command»Command Signal Configuration»Step Resolution in Steps / Motor Rev. If the drive does not support the desired value it will coerce down to the nearest increment that is supported. All of the microstepping will then be configured on the drive.

 

0 Kudos
Message 6 of 7
(4,549 Views)
Highlighted
Solution
Accepted by topic author tir38

Thanks for everyone's help. I got it working.

 

SOLUTION:

In addition to setting the tooth count to 50 (1/4th of the 200 steps/rev), I also needed to run an "Auto X-Smoothness Probe" under the X-Smoothness tab. Now the jogging left/right works.

0 Kudos
Message 7 of 7
(4,545 Views)