Motion Control and Motor Drives

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Over-current Error with NI-9503

Highlighted

Over-current Error with NI-9503

Hello,

 

So, NI-9503 is currently on cRIO-9035. A few days ago, I've accidentally short circuited the power supply that was connected to NI-9503 and cRIO-9035. After replacing the power supply, they are both now powered by a 24V 5A power supply.

 

However, I have been constantly getting Error code 4: over current whenever I try to enable the motor. This error is returned even when no motor is connected. I've also swapped the motor and power supply which also return the same error. This was working before the old power supply got short circuited. (Note: the fault is cleared whenever the program starts)

 

Do you guys think that short circuit may have damaged some components in the motor driver? The old power supply is 15V 8 A.

 

The compact RIO should be fine because other modules (digital In/Out...) are still functioning.

 

Please let me know if any other information is required.

Best regards,

Lucas

0 Kudos
Message 1 of 4
(786 Views)

Re: Over-current Error with NI-9503

Have you tried swapping the module to different slots in the cRIO? Occasionally there is just damage to a specific slot. 

0 Kudos
Message 2 of 4
(650 Views)

Re: Over-current Error with NI-9503

Hello, thank you for replying Smiley Happy

 

Yes I have swapped in several different slots already but the problem still exists.

 

 

0 Kudos
Message 3 of 4
(644 Views)

Re: Over-current Error with NI-9503

Is it possible some things changed in your project? 

It could be worth going through, check the wirings on the motor, and set up the LabVIEW example project to test.

The example project can be found in LabVIEW by going File -> Create Project... -> Sample Projects: Softmotion -> Stepper Drive (NI 9503). Then you want to open up the html file in the project and follow the steps to set up the project.

0 Kudos
Message 4 of 4
(627 Views)