Measurement Studio for VC++

Showing results for 
Search instead for 
Did you mean: 

Sometimes NI VISA can't find USB-TMC device.


I connect several USB Test and Measurement Devices to my PC and turn on these USB Test and Measurement Devices devices, then there is a case to not find some devices. I use NI-VISA 18.0 on windows 10. I tried some solutions but, it didn't resolve. I tried to change only NI-VISA version to 5.4, this problem doesn't occurred. But i should use NI-VISA 18.0 because of NI-VISA 5.4 doesn't support Windows 10.


Do you have any solution to solve this problem?


I tried disabling Fast Startup on Windows 10, updating USB Test and Measurement Device Driver. However, these solution did not lead to the resolution.


0 Kudos
Message 1 of 2

Hello Satoshi,


May I get the number of devices you are trying to connect at once? Are you also using NI-DAQ, or only USB-TMC devices?


May I get a clarification on "there is a case to not find some devices."

Does that mean that only some of the devices are recognized but not all by NI MAX?

If only some are recognized but not all, what happens if you only connect a single device?

Is it always the same devices that aren't getting recognized by NI Max?


If you prefer Japanese:日本語でお書き頂いても問題ありません。



Applications Engineer

National Instruments Japan

0 Kudos
Message 2 of 2