Measurement Studio for VC++

cancel
Showing results for 
Search instead for 
Did you mean: 

Looking for C/C++ include files.

Highlighted

Hi,

I have been asked to fix a bug in a C++ program that uses the NI-488.2 driver.  The engineers that worked on the project before have all left the company. I have the source code to the project, but it appears they did not save the NI include files that are used in the project. So I can not find NiCommonComponent.h, NiGraph3DComponent.h, NiUiComponent.h and NiUiCommonComponent.h.

 

I searched this forum and I have seen others that are looking for various header files. It looked like I needed to down load "Measurements & Automation", when I looked for that; the NI site indicates that it is part of the other driver downloads. So I installed the NI-Visa driver. I selected the C/C++option as part of the install. But still no files. 

 

I am obviously missing something, either the wrong downloads or the wrong options.  This project is still being built with Visual Studio 6. No one knows why a newer version of Visual Studio is not being used.Maybe some license issue?

 

I have never worked with NI tools, so I know nothing about the program nor the NI products.

 

Thanks.

 

0 Kudos
Message 1 of 5
(258 Views)
Highlighted

You need Measurement Studio not Measurement & Automation Explorer. That are two very different products from NI. Measurement Studio is an extension for Visual Studio to do measurement applications and Measurement & Automation Explorer is the application that is used to manage all NI hardware in your PC and connected to your PC.

 

Now Visual Studio 6 is almost 23 years old and won't install into Windows 7 or newer at all so you are working with an obsolete product on an obsolete platform. That's definitely asking for problems in a myriad of ways (aside from being very insecure even if you do it in a virtual machine).

 

The oldest version you can download here is Measurement Studio 2010, which only supports Visual Studio 2005 to 2010. You may be able to get a download link from NI support for an older version such as 7.x or 8.x which might still support Visual Studio 6, possibly might require you to also install this updater afterwards. Also you will need at least the Professional Edition of Measurement Studio because of the use of the 3D graph component.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 2 of 5
(207 Views)
Highlighted

Thanks for the information. I can only download the 2019 version, the 2010 versions (and other older) are locked without some sort of license number. On a whim, I downloaded the 2019 version in the hopes that some include files would appear, but none that I was looking for were downloaded. Is that the reason they stayed with VS6, because the newer Measurement Studios were all .Net?

0 Kudos
Message 3 of 5
(200 Views)
Highlighted

Yes you need a valid, current maintenance contract for Masurement Studio to be able to download older releases. That is an extra option when you buy the current release and needs to be renewed every year to keep that perk available. As to when Measurement Studio moved form ActiveX to .Net components I have no idea. I never used it, and generally avoid both ActiveX and .Net whenever possible.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 4 of 5
(86 Views)
Highlighted

Thanks for the clarification.  In the end, we found the original PC that was properly setup and used that.

0 Kudos
Message 5 of 5
(65 Views)