From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Measurement Studio for .NET Languages

cancel
Showing results for 
Search instead for 
Did you mean: 

licenses.licx Measurement Studio 2015 with MS Visual Studio Express 2013

Hello

I have installed MS Visual Express 2013 and Measurement Studio 2015 for Visual Studio 2013.

When debugging my application the following error is there: 

NationalInstruments.UI.WindowsForms.Slide is unlicensed

I modified the licenses.licx file with the following items:

NationalInstruments.UI.WindowsForms.PropertyEditor, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Legend, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.LedArray, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Tank, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.ToolStripPropertyEditor, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.InstrumentControlStrip, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.NumericEdit, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.NumericEditArray, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Meter, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Led, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.SwitchArray, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.WaveformGraph, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.ScatterGraph, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Slide, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.ComplexGraph, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Knob, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Switch, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.DigitalWaveformGraph, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Gauge, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a
NationalInstruments.UI.WindowsForms.Thermometer, NationalInstruments.UI.WindowsForms, Version=8.9.35.246, Culture=neutral, PublicKeyToken=18cbae0f9955702a

 And still the same error at the first line, when creating my first item with NI in the source.

I have spent hours meanwhile, can't find any help on the web how and what to modify

to make that thing work...

 

Has anybody had similiar problems and a usefull solution that make measurement studio work with ms visual studio?

 

thx

Andy

 

0 Kudos
Message 1 of 2
(4,582 Views)

Hi there,

 

I only can advise you to have a look to the following links:

http://zone.ni.com/reference/en-XX/help/372636F-01/mstudiowebhelp/html/licensingnetwithoutintegratio...

http://zone.ni.com/reference/en-XX/help/372636F-01/mstudiowebhelp/html/unlicenseddialog/

http://zone.ni.com/reference/en-XX/help/372636F-01/mstudiowebhelp/html/troubleshootinglicensingerror...

 

Or to contact your local NI branch if you have SSP. 

 

Hope that is helping! 

Certified LabVIEW Architect (CLA)
0 Kudos
Message 2 of 2
(4,510 Views)