Measurement Studio for .NET Languages

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

common.dll deploy problem

Solved!
Go to solution
Highlighted

Hi, all

 

I have a valid copy of Measurement Studio 2012, and I had no problem in the deployment of the software that developed for my users. However, since the Measurement Studio 2015 came out, all in sudden that the deployment process complains that "missing valid Measurement.Common.dll". I tried many ways to avoid this problem, one of the methods is to ask user to install Measurement Studio 2015 Evaluation copy, and then install the package that I developed. It seemed working for some users but not for others (under the Windows 7). Please tell me how to get around this problem. Thank you in advance.

0 Kudos
Message 1 of 4
(177 Views)

Sorry, the complain was "NationalInstruments.common.dll"...

0 Kudos
Message 2 of 4
(169 Views)

Hi dffang,

 

It's not clear if the required assembly is missing from your development machine, or only from the deployment machines.  If the DLL is missing in both places, please see this KB article that talks about the issue and how to resolve it.

 

If the DLL is missing only from the deployment machines, you may need to create an installer to package it for easy installation.  Measurement Studio 2015 makes this easy with the included installer builder.

 

Can I Create an Installer for My Measurement Studio Program Using InstallShield?

 

Thanks,

Michael B.
Technical Support Engineer
National Instruments
0 Kudos
Message 3 of 4
(148 Views)
Solution
Accepted by topic author dffang
05-18-2019 02:31 AM

Hi, Micheal

 

I think I have identified the problem. Somehow the app.config file in my application was altered. The relevant contents was:

<dependentAssembly>
<assemblyIdentity name="NationalInstruments.Common" publicKeyToken="DC6AD606294FC298" culture="neutral"/>
<bindingRedirect oldVersion="0.0.0.0-13.0.40.188" newVersion="15.0.40.14954"/>
</dependentAssembly>

 

I changed it back to: newVersion="13.0.40.188", and it worked. 

 

Thank you for your advice.

 

Dufei

0 Kudos
Message 4 of 4
(137 Views)