Measurement Studio for .NET Languages

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

The type or namespace name 'WebForms' does not exist in the namespace 'NationalInstruments.UI'

Hello.  I've created a new Project (Visual C# - Measurement Studio - NI Class Library).  In that Project, I have a Class with...
 
using NationalInstruments;
using NationalInstruments.UI;
using NationalInstruments.UI.WindowsForms;
 
...and I'd like to replace the reference to WindowsForms with a reference to WebForms.  However, when I do so and try to build, I get, "The type or namespace name 'WebForms' does not exist in the namespace 'NationalInstruments.UI'".  When I try to add a Reference to NationalInstruments.UI.WebForms in my Solution Explorer, there's no obvious Component Name to add...
 
 
...I'm expecting to see one called "National Instruments Web Forms Controls".
 
Please advise.
0 Kudos
Message 1 of 12
(7,743 Views)
Ask National Instruments to develop Web Forms Controls for us Smiley Wink
0 Kudos
Message 2 of 12
(7,742 Views)
The Measurement Studio User Manual (v8.0.1) has a section, "Chapter 2 - Measurement Studio .NET Class Libraries - ASP.NET Web Forms Controls."  Is this a lie?
0 Kudos
Message 3 of 12
(7,740 Views)
The WebForms controls only show up in the toolbox for a web based (ASP.NET) project like a new website. Go to File>>New>>WebSite in VS. As far as the NI Class Library not working, it works for me. However, when you create a NI Class Library using our wizard the wizard adds using statements to your project. If you remove WindowsForms assembly and add the WebForms assembly you will get a compile error for the statement:
 
using NationalInstruments.UI.WindowsForms;
 
Just remove that statement and everything builds fine.
0 Kudos
Message 4 of 12
(7,734 Views)
> If you remove WindowsForms assembly and add the WebForms assembly
 
That's my point: the WebForms assembly does not appear in the "Add Reference" dialog for me (SEE image).  What, specifically, do I need to do to add the WebForms assembly to my Visual C# - Measurement Studio - NI Class Library Project?
 
0 Kudos
Message 5 of 12
(7,730 Views)
Are you using VS2003? The WebForms assembly only works with VS2005 (ASP.NET 2.0). You must install MStudio for VS2005 support and use VS2005 to get WebForms.
0 Kudos
Message 6 of 12
(7,727 Views)
I'm using...
 
Microsoft Visual Studio 2005
Version 8.0.50727.42  (RTM.050727-4200)
Microsoft .NET Framework
Version 2.0.50727
Installed Edition: Professional
NI Measurement Studio   8.1.20.256
Measurement Studio for Visual Studio 2005
0 Kudos
Message 7 of 12
(7,725 Views)
Try looking in the Assemblies\Current folder for the asembly (under your installdir). Also try looking in the version specific folder under Assemblies and in the GAC.
0 Kudos
Message 8 of 12
(7,721 Views)
Based on the fact that that folder contains "NationalInstruments.UI.WindowsForms.dll" I assume I'm looking for "NationalInstruments.UI.WebForms.dll".  That .dll is not found anywhere on my hard drive.  Please advise.
0 Kudos
Message 9 of 12
(7,717 Views)
Try to repair the install.
0 Kudos
Message 10 of 12
(7,709 Views)