Showing results for 
Search instead for 
Did you mean: 

I get an exception error when launching NI Measurement and Automation Explorer


The CniDMFuiProvider::Initialize plug-in caused an exception in the CmxExecutionThreadPool::DoWorkNonUI function in the MAX process.  What is mean.  I cannot access NI MAX after I ignore this message, I will   have to kill the process.

0 Kudos
Message 1 of 4

Did it say which plug in caused the issue?  Would you mind creating a technical support report from MAX and attaching it.

0 Kudos
Message 2 of 4

Greetings nintel


This type of NI-MAX exception is associated with a corruption in some files of the NI-MAX and has been solved in the past by either removing a MAX database corruption or repairing the installation of NI-MAX. Have you tried going to Control Panel>>Programs and Features>>NI Software and repairing NI Measurement & Automation Explorer? Please let us know if any of those steps solve the problem. Have a nice day.

Luis J.
Applications Engineer
National Instruments
0 Kudos
Message 3 of 4

I had the same issue with MAX version 20.0 this afternoon. I tried to repair MAX using NI Package Manager but this didn't resolve the issue. I also tried to reset my MAX database per the suggestion in this thread but that also did not resolve the issue. Eventually I used the package manager to remove and then reinstall both MAX and LabVIEW. This did resolve the issue but at the cost of most of my afternoon.

0 Kudos
Message 4 of 4