Showing results for 
Search instead for 
Did you mean: 

Digital DIO pins - no response

Digital DIO pins - no response




I am running into trouble with a USB-6009. I cant seem to get the DIO to output anything. I have also noticed that the +5V output pin is not producing that output, only the 2.5V output pin is producing what it is expected to.


I tried turning them into a DI (Port 0 and Port 1) and everytime I drive one of them high, the rest are driven high too.


I ran the self-test on Measurement & Automation and it checks out fine.


Please let me know if there are any further tests I can conduct on the DAQ.



0 Kudos
Message 1 of 2

Re: Digital DIO pins - no response

Hi Rami,


I have the following questions/suggestions,

1) Is the behaviour with the DO occurring when using test panels?

2) Is the device attached to an external USB hub? If so, I recommend attaching directly to the PC. Often times an external hub does not provide the correct power nor the controller requirements the USB devices require.

3) Is the behaviour repeatable on another USB Port, PC?

4) What version of DAQmx do you have installed?

0 Kudos
Message 2 of 2