Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

"Use IMAQdx Unconfigure Acquisition.vi to unconfigure the acquisition."

Hello,
We are calling "IMAQdx configure grab" numerous times in our sequence to start AVI acquisitions.  I have just noticed in the help file for this that there is the sentence at the end "Use IMAQdx Unconfigure Acquisition.vi to unconfigure the acquisition."  I do not see a vision palette item for this, nor do I find it when doing a windows search of the labview directory.  Where can I find this tool, and what does it do?  In opening the IMAQdx configure grab.vi, I see there is a "start acquisition" used.  I assume I should be doing a "stop acquisition" at some point?  Is this all that is done by IMAQdx Unconfigure Acquisition.vi (wherever it is)?

Thanks
David Jenkinson
0 Kudos
Message 1 of 6
(2,130 Views)
Highlighted

David,

I was able to find the IMAQdx Unconfigure Acquisition.vi.  Below is a screenshot of the palette showing its location:



It basically removes any configuration information from the IMAQdx session.  To best understand the configuration information it removes, it is helpful to look at the context help for IMAQdx Configure Acquisition.vi:



We can see here how the Continuous? and Number of Buffers parameters are used to configure the session.  Continuous? will specify whether or not the camera continually acquires images at a hardware timed rate, and Number of Buffers will specify memory allocation for the session.  The IMAQdx Unconfigure Acquisition.vi will clear out these parameters from the session.

Regards,
Luke H

 

Message Edited by Luke H on 03-12-2007 02:29 PM

Message 2 of 6
(2,118 Views)
thanks ya I found it. 
What isn't real clear though, is that it appears you need to do a "stop acquistion" in addition to the "unconfigure acquisition", since within the "configure grab" there is both the configure acquistion and start acquistion.   It seems like the should be an "unconfigure grab" to do these 2 things for you, in the same way configure grab does the 2 setup steps.

Anyway thanks for the reply
David Jenkinson
0 Kudos
Message 3 of 6
(2,112 Views)

HI,

I run a VI, I receive Errors, saying that ... '' open camera , close camera , get iamge, etc.'' all this functions are missing and the Sub VI s are not executable.

I dont know how to solve these errors :'( ...  could any body help me?

lg,

M.

0 Kudos
Message 4 of 6
(1,665 Views)

Hey Marygreen,

 

It looks like you are missing the Imaqdx drivers. First, check that they are installed by going to Measurement and automation explorer and expanding the software tab. Then, look for this:

2.png

 

If it is installed, go to NI License Manager and check for the vision acquisition software--make sure it is activated.

 

1.png

 

If it is installed and activated, try repairing the install. It is possible the files were not put in the correct locations, which is why you are seeing that problem.

 

If you do need to install it, you can locate it here: http://joule.ni.com/nidu/cds/view/p/id/2137/lang/en

0 Kudos
Message 5 of 6
(1,645 Views)

Thank you very much D Smith.Smiley Happy

The problem is that Vision acquisition software is not activated , I just realizes that the Academic campus version that I have does not have a license for that , so I ordered the vision acquisition software, with 75 % discount  :womanvery-happy: , for 102.25.

Well let me see if my program will run after activating that.

Regards,.

MAryam Zeinalzadeh

0 Kudos
Message 6 of 6
(1,634 Views)