Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

"NI-imaqdx devices" folder not showing up in NI-MAX/USB Cameras not recognized

Solved!
Go to solution

Hi everybody,

 

I have a Dell M6700 running Windows 7 64-bit, Labview 2012 32-bit, NI-imaq 4.6.4, NI-imaq I/O 2.8, NI-imaqdx 4.3, and NI-Vision Development Module 2013, NI-MAX 5.5.1, in addition to other NI modules like serial, xnet, etc.

I have two webcams I am trying to use with Labview. One is the Dell integrated webcam, the other is a Logitech C500 USB webcam.

Neither of the webcams are shown in MAX. And in fact, the "NI-imaqdx devices" folder doesn't even show up.

Both of the webcams work perfectly with the "Dell Webcam Central" software, AMCAP software and Skype. The only software I have that doesn't see the webcams is NI-MAX.

I have uninstalled and reinstalled everything, including the OS, with no luck at all.

It seems like this is a common problem but I can't find any answer except for one possible cause. In one of the posts I read, one of the AE's said that NI-MAX requires the "DevicePath" key in the registry so I wonder if a registry problem is the cause.

What exactly is NI-MAX looking for to recognize webcams and create the "NI-imaqdx devices" folder?

 

Thanks for the help in advance,

Mike

 

0 Kudos
Message 1 of 24
(15,549 Views)

MAX interfaces with USB cameras Microsoft's DirectShow interface. Honestly, I'm not sure what is done in the registry to make this happen, but a reinstallation of the drivers should fix any issues. Try uninstalling Vision Acquisition Software and reinstalling it. Restart your computer after the uninstall as well as the reinstall. This should fix any registry issues.

Applications Engineer
National Instruments
0 Kudos
Message 2 of 24
(15,522 Views)
Solution
Accepted by topic author awestek

I'm wondering if this might be a manifestation of a recent issue that cropped up. Can you try renaming "niu3v.dll" in C:\Windows\SysWow64 and then close/re-open MAX?

 

Eric

Message 3 of 24
(15,521 Views)

Thanks for the quick reply Eric I appreciate the info. I have tried uninstalling and reinstalling all software (including the OS) a few times and nothing has worked.

 

 

Bluecheese....YOU ARE THE MAN!!!!!!

I renamed the file to niu3v(old).dll and it fixed everything! The "NI-imaqdx devices" folder is there, both the webcams are listed and they work perfectly!

I really appreciate the help!!!!!!!!!!!!!!!!!!!!!! I have spent so much time trying to get this to work it is ridiculous.

If I could impose on you one, (or two), more questions I would really appreciate it; now that I have done that and it fixed the problem, could you please elaborate on the issue you were referring to in your post and what should I do now? Do I just leave it as is or is there something I should follow up with?

 

Thank you so much,

 

Mike

0 Kudos
Message 4 of 24
(15,511 Views)

Hi Mike,

 

There is a fairly recently opened issue (CAR 445818) that has been reported by some people that causes some plug&play notification support related to USB3 Vision cameras to fail to initialize on some systems. This error causes IMAQdx device enumeration to fail completely and thus no cameras to show up in MAX.

 

This issue is already mitigated by a change  in the upcoming IMAQdx 4.3.5 version that should be released any day now. The fix I gave you simply disables USB3 Vision camera support (which you aren't using if you are using a DirectShow camera).

 

Eric

Message 5 of 24
(15,509 Views)

Thanks again BlueCheese!

 

That's great to know because I am researching NI cameras for a project we are getting ready to start. I was just using the cheap webcams to do some rough testing before we commit to more expensive equipment. Hopefully the new IMAQdx will be available by the time we buy the NI cameras.

 

Again, I really appreciate the information and help!

 

Mike

0 Kudos
Message 6 of 24
(15,507 Views)

I have the same problem with imaqdx. I had unistalled labview and I had installed again but unfortunately imaqdx didn't appear in ni max. I was looking for niu3v.dll in my computer but I haven't. Could you please help me to resolve the problem.

0 Kudos
Message 7 of 24
(14,760 Views)

Hellp  tiho,

What is your OS? 32-bit or 64-bit?

You can find "niu3v.dll" in (depending on you OS)

- C:\Windows\System32

- C:\Windows\SysWOW64

0 Kudos
Message 8 of 24
(14,750 Views)

Hi

 

I am using OS 64-bit. I have no such a file niu3v.dll. What I can do? Is it a problem?

0 Kudos
Message 9 of 24
(14,746 Views)

Hi Tiho,

 

Did you update your IMAQdx driver as suggested above? If you need to download the latest version, you can go to http://www.ni.com/download/ni-vision-acquisition-software-2014.02/4584/en/. This driver still has support for Windows XP. 

Rahul B.
0 Kudos
Message 10 of 24
(14,726 Views)