Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

external trigger for two camera with frame grabber

Highlighted

Hi there

i am newbie with NI

 

how i trigger two camera simultanously to capture images in the same time exactly?

i use 2 frame grabber PCI 1422, 2 camera Pulnix TM1040, BNC 2121, PCI 6602, IMAQ D2504, and IMAQ D100.

As far as i did is i can trigger each camera with one trigger (the trigger is generated by BNC-2121), so i have to triger twice to capture image from two camera.

But all i want is one external  trigger can capture the image from two cameras at exactly the same time.

i am using LABVIEW 8.5 with IMAQ 3.8 and VAS 8.5

here is i attach the VI.

so anyone can help tell me what to do?

 

thank you

0 Kudos
Message 1 of 12
(1,980 Views)

Your code to configure the cameras to acquire when a trigger is received looks correct.  You should just be able to send your trigger from your PCI 6602, through your BNC 2121, then branch off that trigger to both camera trigger lines.  This would mean that you do not use the D2504 cable to connect any triggers.  Let me know if you have any additional questions about specifics of where connections should go.

Zach C.
Field Engineer
Greater Los Angeles

0 Kudos
Message 2 of 12
(1,963 Views)

hi..Thanks Zach for your reply

i have further question.

is there any setting for the camera to be triggered externally?because i can't find the way i will do that. it seems like the camera does not have external trigger line. that's why i thought i need the D2504 cable.

and how i set and connect PCI 6602 and BNC-2121 , so that the BNC can send the trigger signal correctly to the camera

 

big thanks

0 Kudos
Message 3 of 12
(1,954 Views)

inubus,

 

I took a second look at your camera specifications and it looks like the trigger is going to have to come from the Digital Input.  Take a look at the page 5 of this pdf manual, this should be how you configure your camera to acquire after a trigger.  I am still looking into how to route the trigger signal from your BNC 2121 into the D2504 cable and through your PCI 1422 back to the camera.  I'll let you know what I find out.

Zach C.
Field Engineer
Greater Los Angeles

0 Kudos
Message 4 of 12
(1,939 Views)

i already branched the wire from BNC 2121 to two different IMAQ D2504 (the T0 slot) which is connected to D100 and to PCI 1422.(I follow the instruction manual of IMAQ D100 cable: http://www.ni.com/pdf/manuals/371868a.pdf). But still i have to trigger twice for capture image from two camera. I can't make one trigger for both cameras at the same time

0 Kudos
Message 5 of 12
(1,918 Views)

Your hardware configuration seems to be connected correctly, but if you have the same trigger signal going from your DAQ card to both trigger lines for each camera, you should not have to send two trigger signals.  What do you mean when you say, "I have to trigger twice".  Are you sending two digital pulses from your DAQ card?  Are these coming from different channels on your DAQ card?  My suggestion is to reduce your code to one camera, make sure that the trigger is working as expected, then just copy the second code over and make sure both triggers are being configured before the signal is sent.

 

There are a few example programs you can use to test whether or not you are able to trigger correctly.  The example I would suggest looking at is LL Triggered Snap.vi  located at Help » Find Examples then when the Example Finder window opens navigate to Hardware Input and Output » IMAQ » Signal Input and Output » LL Triggered Snap.vi 

 

Zach C.
Field Engineer
Greater Los Angeles

0 Kudos
Message 6 of 12
(1,890 Views)

My VI is build by copy one code that worked as i want for one camera, so then i just copy and apply that code to make this work with two camera. But when i trigger this system, camera one is capturing the image, but the camera two is can not capture the image before camera 1 finished the acquisition. So after camera 1 finished the acquisition, i have to trigger once again to running camera two. (The trigger came from the same line)

0 Kudos
Message 7 of 12
(1,879 Views)

That is very strange behavior that the original trigger is not picked up by both cameras if they are connected to separate PCI cards.  I'm going to round up similar hardware and test this out and let you know what I find.

Zach C.
Field Engineer
Greater Los Angeles

0 Kudos
Message 8 of 12
(1,861 Views)

Is there any requirement that i have to use SCSI hard drive to capture and save the image to my hard drive?Because now i am using SATA hard drive. I wonder if this is the cause my problem

0 Kudos
Message 9 of 12
(1,857 Views)

One issue in your code is that both sequences are using identically-named images. This is going to cause some very odd behavior since both cameras might be acquiring into the same images.

 

Eric

0 Kudos
Message 10 of 12
(1,855 Views)