Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

basler runner rul1024-57gm GigE line scan camera with broadcom network card

Solved!
Go to solution

Hi, I am learning to use a basler runner GigE line scan camera with labview but meet with some problems, please help me.

 

My software and hardwares:

labview 8.6, vision acquirition software 2010,

basler rul1024-57gm camera, broadcom Netlink(TM) Gigabit Ethernet Network Card (It not a intel pro 1000, so the driver is the also the broadcom driver).

 

Q1: In the max, there appears two cameras, while I only connect one. There is a red X in the other one, and a error of camera in use.Capture1.PNG

 

Q2:

The camera can acquire image, but in the camera attributes, there is no information of trigger, so it seems I cannot set the trigger in labview, while the camera does support trigger mode.

Capture2.PNG

 

0 Kudos
Message 1 of 8
(2,505 Views)

Hi, I have found the reason, I uninstall the driver the camera company supplied, there is only one camera in MAX now, and the trigger setting options also come out.

 

But the problem is it do now acquire image now, it gives out error 0xBFF69031, 

The system did not receive a test packet from the camera.  The packet size may bee too large for the network configuration or a firewall may be enabled.

 

I have disable the firewall, and I decrease the packet size form 8000 to 4000, it still do not work.

 

Please help.

0 Kudos
Message 2 of 8
(2,502 Views)

Hey ustcmiaor,

 

There are a few items we can try from Troubleshooting GigE Vision Cameras for your device.  Once opening this page, navigate to 'The camera can be opened in MAX, but it does not acquire images.'  I suspect your issue pertains to the High Performance Driver.

 

Let me know how it goes!

 

Lynn

National Instruments
Senior Systems Engineer
0 Kudos
Message 3 of 8
(2,489 Views)
Solution
Accepted by topic author ustcmiaor
08-27-2015 04:09 PM

Hi Lynn,

 

I read the page and do find the solution. In fact, I just need to further reduce the packet size to 1500. It works well now.

 

Thank you~

0 Kudos
Message 4 of 8
(2,487 Views)

Hey,

 

I'm glad to hear its working well now! Enjoy!

 

Lynn

National Instruments
Senior Systems Engineer
0 Kudos
Message 5 of 8
(2,470 Views)

Hi,

I have the erroe message. How do you reduce the packet size?

Thanks for your help!

0 Kudos
Message 6 of 8
(2,163 Views)

Hello,

 

You can reduce the packet size within Measurement & Automation Explorer in the Acquisition Attributes tab. (See Case 3 in Troubleshooting GigE Vision Cameras under 'The camera can be opened in MAX, but it does not acquire images').

 

Lynn

National Instruments
Senior Systems Engineer
0 Kudos
Message 7 of 8
(2,155 Views)

Hi,

I indeed read the pages. I have had needed to reduce the packet size and disable the firewall. Now it works well.

Thanks

0 Kudos
Message 8 of 8
(2,153 Views)