From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

Slow building / saving of vision assistant block

Hi I have a Vision Assistant block that I use to perform tests on electronic components.

 

SlowBuildingVisionAssistantBlock.png

 

It contains 20 Color Pattern Match blocks, one for each pin, and a couple of overall processing blocks.

Problem is if I need to make a change (which can be frequent), say change the name of a block or tweak a parameter in Vision Assistant, when I close it, it takes between 1.5 and 2 minutes to do whatever it does under the covers before I can use Labview at all.

 

Should this be considered normal? It's frustrating (and personally I feel unnecessary) that it would take so long just to update a block, given the machine it's on, specs here:

 

SystemSpecs.png

 

 

It doesnt look machine related, I had the same problem on the previous system before it was upgraded a couple of months ago. Nor OS, previously we had Windows 7 and now its Windows 10.

 

Thanks for any comments.

 

 

0 Kudos
Message 1 of 5
(3,418 Views)

Hi TripleAntigen,

 

Thank you for including your code; I went ahead and tested this behavior myself by making a small change to the vision assistant and clicked finish. Unfortunately, I experienced the same behavior. When you make a modification to the vision assistant and save changes LabVIEW has to regenerate all of the code over again which is why it is taking this long every time you change something.

 

You could potentially split this Vision Express VI up into multiple express VIs so that it doesn't have to generate the entire code base every time.

Message 2 of 5
(3,399 Views)
hi
first I could say that yes it is normal
but for preventing wasting your time just do this
in NI Vision Assistant go to tools menu and use create labview vi
in this case Vision Assistant will be convert the vode into labview code and you use this code inside your code and you will be have more flexibility to change any part you want also you can do it without wasting time and at then end your code will be work faster
just study the code that Vision Assistant create for you and use the part of that that work for you
Message 3 of 5
(3,335 Views)

Thanks very much Hatef.fouladi, I am taking your advice and trying to convert the code to Labview code using the process described. But I am not having any luck.

 

If I open Vision Assistant from the Labview's Tools -> Vision Assistant...  menu item, I can see the Create Labview VI option, its greyed obviously because I have not created a script. But I already have an Express block as shown in the image in my first post, and if I double click on that, it opens the block script in Vision Assistant, but this time there is no Create Labview VI.

 

Am I doing something really stupid? Thanks

 

Chris

0 Kudos
Message 4 of 5
(3,220 Views)
Dear Member TripleAntigen
Do not open VS from inside labview
you can run VS without using it inside labview
go to National instrument folder yo can find VS then click on to run
import your example image and then use create labview vi also you can select with parameter is constant or terminal in that vi after creating vi you can open it and see related code that you need it then you can copy that part (you need some edit ) and use it in your vi
Message 5 of 5
(3,213 Views)