Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

Set a Coordinate System in Vision Assistant has wrong x-axis angle

Highlighted

I use Vision Assistant 2019, 32 bit.

When I have 2 points from Find Circular Edge, I use Caliper: Line Fit, to make a line from that 2 points.

 

And then Set Coordinate System, using angular motion mode, which the only X-axis angle that I can refer to is the line from Line Fit.

Finally I saw that the X-axis angle is not related to the line that I refer to.
Is there any explanation? 

Or is there other method that I can set the x-axis correctly to the line?

 

Thanks.

 

xx.png

0 Kudos
Message 1 of 7
(295 Views)
Highlighted

Hi

 

I had tested the Set Coordinate Function in different angles of the detected point. All my coordinate showing perpendicular 90 degree. I believe you have the Geometry setup in rotation mode, therefore your set coordinate doesn't look perpendicular. 

Elson9988_1-1594105351898.png

 

Elson

Technical Support Engineer 

NI | Penang

 

0 Kudos
Message 2 of 7
(164 Views)
Highlighted

Hi Elson,

 

Thank you. Unbelievable someone looked at this question.

My question may not be clear to you, so I would repeat:
1. Get two points
2. Draw a straight line between those two points.

3. Set a coordination system on one of those points, with X exactly on the straight line that just made (and Y will be perpendicular to the straight line)

 

You may try with any picture that has two circles.

 

-Dog

0 Kudos
Message 3 of 7
(152 Views)
Highlighted

Hi man

 

Can you clarify how to draw the red line? I tried the caliper but I did not get to draw a straight line between two points. 

 

Elson

0 Kudos
Message 4 of 7
(144 Views)
Highlighted

Hi,

 

    You can use this function to build a coordinate system

 

1.png2.png

   

0 Kudos
Message 5 of 7
(123 Views)
Highlighted

Let me teach you.

Select Caliper, and then inside Caliper, select "Line Fit".

0 Kudos
Message 6 of 7
(96 Views)
Highlighted

This is exactly what I want.

But it seems impossible in Vision Assistant. Or it could be a bug..

0 Kudos
Message 7 of 7
(95 Views)