From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

Not working of AVT stingray F146B CCD camera in Labview, but it works in NI MAX

I have CCD camera, AVT Stingray F146B. And I want to use it with the labview. The camera well works in the NI MAX. I can take a grab some images by using NI MAX. However the camera does not work in the labview. When I run the labview program, the error message is appeared.

 

Error-1074360311 occures at IMAQdx Poen Camera.vi

possible reason: Camera not found.

 

I think that the old version of the NI vision acquisition can be a reason. So I installed with new vision. I use now NI-IMAQ 4.7, NI-IMAQdx 4.0, NI-IMAQ I/O 2.6.

 

What is the problem? What shall I do for using it?

 

Attached is my imaging program.

0 Kudos
Message 1 of 3
(3,438 Views)

Lets try something quick. If you open up an example program (Help -> Find Examples) and run a simple snap. Does that work?

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 2 of 3
(3,431 Views)

I am guessing your camera is cam1 and you are trying to open cam0.  Check what the name of the camera is in MAX and make sure you select the same name in your program.

 

Bruce

Bruce Ammons
Ammons Engineering
0 Kudos
Message 3 of 3
(3,423 Views)