Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

NI Vision did not initialize properly

Solved!
Go to solution
Highlighted

The initial problem (NI Vision did not initialize properly) has been fixed, my issues (also mentioned in an earlier post) still remain.  Listed below for convenience...

  1. The ability to select .icd files from the tree doesn't work with some .icd files.  I had to backdoor MAX by editing the .iid file to use the .icd file I wanted to use.
  2. I can't change settings while a Grab is in progress (this is very inconvenient when trying to make quick settings changes).
  3. Can't select .icd file using the File window and casual users have no idea where the .icd files need to be stored.  Need ability to select a .icd file that's not in the IMAQ\Data folder.
  4. The new style dropdown (to make consistent settings selection across IMAQ and IMAQdx) is difficult to use and makes it difficult to see the settings that you really want to use.
0 Kudos
Message 11 of 12
(169 Views)

Sorry for the inconvenience regarding the MAX experience changes for Camera Link.The MAX experience is different in the newer VAS because now that IMAQdx added support for Camera Link, MAX is using that driver instead of IMAQ. Because typical IMAQdx users don't need to explicitly deal with .icd files (because most IMAQdx cameras support GenICam which requires much less manual intervention), it can be much more cumbersome for the Camera Link use-case if you need to interact with custom .icd files. If you prefer the old MAX experience, there is a registry key you can use to enable the IMAQ experience just as it was before.

 

  • Close MAX
  • Open regedit.exe, browse to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\National Instruments\NI-IMAQ Configuration\19.5.0
  • Add new DWORD called ShowLegacyIMAQItems
  • Right click, Modify, change Value data to 1
  • Re-open MAX

Hope this helps,

Katie

0 Kudos
Message 12 of 12
(162 Views)