Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

MAX doesn't see (older) firewire A camera's

Solved!
Go to solution
Highlighted

Hi,

 

We have several firewire AVT camera's with a firewire A interface (AVT Guppy F046B, F503B, Marlin F033C,...)

They are working correctly (on a Windows 7 PC).

However on a brand new Windows 10 install (Pro, 1909, x64), we are having issues :

The Windows device manager recognizes everything fine :  PCIe firewire card is recognized as "LSI 1394 OHCI Compliant Host Controller", and the camera is recognized as a "NI-IMAQdx IIDC Digital Camera".

However in MAX, the camera doesn't show up.

We are using IMAQdx 20.0.

What I've tried :

- change the firewire card driver to "1394 OHCI Compliant Host Controller" (without LSI). Doesn't make a difference.

- Install AVT Vimba driver and software. Camera is then working perfectly, but of course not recognized in MAX. So I switched back to IMAQdx drivers.

 

It seems as Windows is handling firewire differently than under Windows 7. Any ideas please?

Thanks!

 

0 Kudos
Message 1 of 3
(322 Views)
Highlighted
Solution
Accepted by topic author ThomasV

Hello,

 

IMAQdx 20.0 removed support for Firewire cameras, so the latest release of IMAQdx that supports them is 19.5. If you try 19.5 instead, I would expect those cameras to work just fine on Windows 10.

 

Hope this helps,

Katie

 

0 Kudos
Message 2 of 3
(320 Views)
Highlighted

Hi Katie,

 

Thank you for the explanation. Indeed, when I removed IMAQdx 20 and installed IMAQdx 19.5, the camera was immediatly working in NI MAX.

However a new problem popped up : There was no support for LAbVIEW 2020 with the installed IMAQdx 19.5. (Missing .rc files)

Eventually I just solved this by downgrading to LabVIEW 2019.

 

Now everything is working perfectly.

Thanks for the tip!

 

Thomas.

0 Kudos
Message 3 of 3
(280 Views)