Machine Vision

Showing results for 
Search instead for 
Did you mean: 

IMAQdx Timeout Error 0xBFF6901B

Using IMAQdx with GigE camera, I get a
Timeout error 0xBFF6901B.
What is this error?
0 Kudos
Message 1 of 8
Greetings, and thank you for using the National Instruments forums. The timeout error you are receiving is usually caused by either a firewall or because you haven't installed the High Performance driver for your Ethernet card. If you have a firewall, try turning it off and seeing if you still get the error. You may need to add exceptions in your firewall to allow your camera to communicate with your pc. If you haven't installed High Performance drivers, directions for doing so are described in the lower part of the following document: Troubleshooting GigE Vision Cameras
0 Kudos
Message 2 of 8

This is an old thread, but I had the same problem with a different solution.

I had one working Basler Camera, and on non working Basler camera. 


Turns out I needed to disable test packets on the non working camera by this procedure:


which states:

The test packet timeout error can also be handled by configuring the Test Packets Enabled attribute for the camera to be disabled in Measurement & Automation Explorer (MAX). Follow these steps to set this attribute:

  1. Open MAX.
  2. Click on the Basler GigE camera under Devices and Interfaces»NI-IMAQdx Devices.
  3. Choose the Camera Attributes tab.
  4. Click on View Options listed right above the camera attributes, and then choose to View All. This allows all camera attributes to be displayed.
  5. Click on Expand All to list all the attributes.
  6. Select the Test Packet Enabled attribute and set it to be disabled.

    That will generate a new error of 0xBFF60493 which will be fixed by this accepted solution: 


    which states:

    In MAX (Tools->NI Vision->Remote Image Options...) and turn off the option to "Display images on remote monitor."


Message Edited by screamingmouse on 05-14-2010 06:52 PM
0 Kudos
Message 3 of 8

I've spent the last several hours trying to troubleshoot a GIGE camera, and this ended up being the issue. Thank you so much for posting this!

Message 4 of 8

I'm getting this same error using a Dalsa Spyder 3 camera. Drivers are updated, the firewall has been bypassed, Test Packets are disabled, and Jumbo Frames have been enabled, but still I'm getting a timeout error. The camera can take images in Teledyne's Sapera software, so I know it's triggering properly.


Is there something else that needs to be changed?

0 Kudos
Message 5 of 8

I am having similar issues with a FLIR A700 camera.  I've tried disabling test packets and other recommended changes.  In MAX, grab works for a little while (30 seconds - 3 minutes), and then I get a timeout.  I was wondering if you had found a solution or can recommend other settings to try.

0 Kudos
Message 6 of 8

I am working with a Basler acA5472-5gm GigE camera and I am trying to trigger image acquisition by using a microcontroller ( Arduino UNO).

To establish this communication I wrote code in LabVIEW. In the beginning the system was working but after a while I started getting this error:


IMAQdx Timeout Error 0xBFF6901B


If you have any ideas on how to solve it, feel free to share:)

0 Kudos
Message 7 of 8



We have same issue, did you find a solution?

Anders Pedersen Sekanina
Sekanina Electronics
0 Kudos
Message 8 of 8