Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Grab and Save to AVI: File Access Denied

Solved!
Go to solution
Highlighted

Hello,

So on this computer I tried to run the default  and slightly edited (download file) Grab and Save to AVI.vi; however, I am met with the error message -1074395992 occurred at an unidentified location. I thought it was a permissions issue but it states that there is full control for all three accounts, albeit that the third account (the one I am using) does not have access to special permissions.

 

Is it a coding error, something wrong with LabVIEW, or a computer issue? I tried restarting but the error persists. Do I have to reinstall LabVIEW or something?

 

Also, the previous error was that Windows 10 Media Player did not have the ability to read the .avi extension so I downloaded a codec pack (K-Lite Codec Pack). Could it be from downloading that erroneously that made it so I don't have the permissions?

 

Anyways, I would greatly appreciate any help or insight on this problem. Thank you so much!

0 Kudos
Message 1 of 3
(199 Views)

Also the problem might be that it is saving to the industrial controller. How could I make the program so that it saves on the computer instead without having to directly connect the program into the computer?

 

If I don't have to directly put the program underneath the computer in NI MAX and keep the programs under the industrial controller. Thank you!

0 Kudos
Message 2 of 3
(184 Views)
Solution
Accepted by topic author venus.luong
03-29-2019 10:24 AM

There could be a few reasons for the behavior that you are seeing, one of which could be that you are trying to write to a file location that you do not have permission to write to or that the file path does not exist on the PC. Could you try saving it to your desktop please by setting the file path to save the picture there? If it works here then it is most likely one of the two reasons that I just mentioned. 

0 Kudos
Message 3 of 3
(160 Views)