Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -1074397145

Hey,

I got a problem with the Image Grabbing in LabView. In MAX I can obtain images from my camera without any problems. As soon as I run some VIs in LabView to obtain some images (e.g. the given examples like HL Grab.vi), I get the following error message:

Error -1074397145 occurred at IMAQ Init.vi
Possible reason(s):
NI-IMAQ:  No interface found.

Although I used the same Interface name in Max and in LabView. My setup:

Sony Hyper HAD camera
NI-IMAQ PCI 1409

Software:
LabVIEW RT 7.1.1
NI-DAQmx 7.4.0
NI-IMAQ RT 3.1.3
IMAQ Vision RT 7.1.2

The PCI 1409 is on a remote system. Do I need to consider this for my interface name in LabView. Or where else could be the problem.


Thanks a lot.

Thiva Albin






0 Kudos
Message 1 of 23
(6,583 Views)
Hi Thiva,

Thank you for contacting National Instruments.  To be able to reference a remote target on a RT system, LabVIEW needs to know of the instance.  Add the remote system as a target to LabVIEW and you should be able to reference it no problem.

Let me know if this helps or not.

Thanks!

Justin Louie
0 Kudos
Message 2 of 23
(6,543 Views)

Hi Justin,

 

Could please explain more details about  how to " Add the remote system as a target to LabVIEW " as I have same problem.


Many thanks,

 

Wei

Message Edited by Way on 01-21-2009 03:47 PM
0 Kudos
Message 3 of 23
(4,991 Views)

Hi Wei,


Justin was most likely describing the following procedure when he said “Add the remote system as a target to LabVIEW”


1)    In Project Explorer, right-click on the project
2)    Select New >> Targets and Devices


This will populate a list of RealTime targets that you can choose from. 

 

Let me know if this helps!  Have a great day.

Kristen H.

0 Kudos
Message 4 of 23
(4,962 Views)
Hi Kristen, Thanks you very much for your help! A. I have tried this before as following: 1.  In "Add Target and Devices on NI1772Camera IMAQ ini 1.lvproj" (NI1772Camera IMAQ ini 1.lvproj is my project name.)2.  Select "Existing device on remote subnet"3.  In "Target and Devices" session, select "Compact Vision System" (other two are "Real Time CompactRIO" and "RealTime Single-Board RIO")4.  In "IP address" session, enter "169.254.15.2" ("169.254.15.2" is the defaut IP address fro MAX\Remote System\ETHCAM\IP settings). (I can snap/grab an image from that by the way.)5. Then click "OK" button....6. Back to "Project Explorer", you can see the "Compact Vision System Target (169.254.15.2, Real Time feature not available)" has been created but the message indicated something is wrong. B. I have tried other selection as following: 1.  In "Add Target and Devices on NI1772Camer IMAQ ini 1.lvproj" (NI1772Camera         IMAQ ini 1.lvproj is my project name.)2.  Select "Existing Target or device", then click one of items in the “Target and device” session3.  Then the "Compact Vision System", "Real Time CompactRIO" and "RealTime Single-Board RIO" will all show  <No Items found> I have attached the screen prints. Could you please have a look for me please? Thank very muck again! Wei
0 Kudos
Message 5 of 23
(4,954 Views)

Hi Way!

 

I think you may have forgotten to attach your screen shots.  Also, could you describe (or attach a screen shot of) the message that indicated something it wrong?  Thanks!

 

Kristen H.

0 Kudos
Message 6 of 23
(4,940 Views)

Sorry, Let try again. I have put some notes as well.

 

Thanks,

 

Wei

0 Kudos
Message 7 of 23
(4,917 Views)
I have the same problem.I am using NI 1722 through ethernet. Although i can grab pictures through MAX and Builder, i get the same error in labview.
0 Kudos
Message 8 of 23
(4,903 Views)
I am using Labview 8.5 and camera has installed labview 8.5.1 RT. Could this be the problem?
0 Kudos
Message 9 of 23
(4,901 Views)

Hi WeiL and grekop,

 

Wei - Thank you for the great screen shots and notes- you were very thorough!

 

Check to make sure that the VI you are running is under the remote system in the Project Explorer.  You can drag it to the correct location if it is not.  If the VI is under My Computer in the Project Explorer, LabVIEW will look for a camera on your local system. 


If this does not work, install NI Vision Acquisition Software 8.5.1.  NI Vision Acquisition Software 8.6 does not explicitly state that it supports the 1722 smart camera, but version 8.5.1 does. 


Let me know if either of these work for you!


Kristen H.

0 Kudos
Message 10 of 23
(4,876 Views)