Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1074360293 IMAQdx Get Image 2 happens constantly with camera Basler

Solved!
Go to solution
Highlighted

- Camera: 2 x acA1440-220um usb3.0 mono

- LabVIEW  2018

- VAS 2018 and drive NI-Imaqdx usb3 vision device                          

- I use a screw cable to connect directly to the usb3.0 port on the pc

- I use the PC with the operating system win 10 pro 64 bit , intel(R) i5 4590 , NVIDIA GTX1050

- Usb 3.0 extensible host controller 1.0

 

Problem is 1 camera timeout error after running for 4 5 hours then this error and It stopped my program . I reset the program, this error appears continuously, I went into Max to run the same error but i try with pylon viewer no error. 

 

Error in LabVIEW and MAX :1074360293 imaqdx get image2.vi, 0xbff6901B timeout.

 

This error is happening continuously day by day but I still have not found a solution.  I have tried many ways on the forum but it still fails.  Can you guys help me solve this problem?

0 Kudos
Message 1 of 3
(469 Views)
Highlighted

I'm having a similar problem with a Basler puA1280-54um  (USB camera).  The camera is software triggered, so the USB bus is not overloaded.  If a connection error occurs the program will re-initialize the connection.  But the error I'm getting is IMAQdx Get Image2.vi Code -1074360217 

 

Error -1074360217 occurred at an unidentified location

Possible reason(s):

An error occurred while acquiring from the camera so the acquisition has been terminated.

 

There is no information about this error.  I assume it is in the Vision Acquisition software.  I'm using VAS 19.0.

I will try VAS 20.0.  

 

Anyone at NI have any information about this code -1074360217 ?  It might help me troubleshoot where the error location is [camera or PC or USB].

 

0 Kudos
Message 2 of 3
(263 Views)
Highlighted
Solution
Accepted by topic author Vu_Anh

Don't know if you've solved this problem yet? Currently I have not found a solution to this problem, I think this is the error between the camera hardware and the pc, say exactly the USB port.
I have a way to deal with it temporarily and it works quite well in my case: When the camera fails, I close the camera and reconnect the camera. That is how I fix it temporarily for my wading situation.
Hope it helps anyone who gets the same error as me.

0 Kudos
Message 3 of 3
(185 Views)