Machine Vision

Showing results for 
Search instead for 
Did you mean: 

Dalsa Camera not working with NI-MAX

Go to solution

I am testing the Dalsa Linea GigE Vision Camera (LA-GM-08K08A) right now to see if it is a possible solution for my inspection system. When using the Dalsa Camera Software Sapera CamExpert, I am able to grab images just fine at the default settings. The problem I am facing is when I connect to the camera through NI-MAX. There is no connection issues but at the same default settings I am getting the timeout error 0xBFF6901B when grabbing an image. The reason I am trying in NI-MAX is I am using VBAI software for my system and if I can grab images from NI-MAX I should be able to grab images using VBAI. I have done most of the solutions that were suggested including disabling firewall and ensuring the network cards can support Jumbo Frames. I have tried to re-install NI-MAX thinking one of the drivers did not install correctly but still I am unable to grab images and I get the same timeout error. Using a Basler GigE Vision Camera, I tested whether NI-MAX was really the problem but I was able to get the images just fine with that camera. Is there something I am missing that is not allowing the Dalsa Camera to work with NI-MAX?

Any suggestions would be helpful. Thanks.

Message 1 of 10

Hi ClaytonFromEdge,


Check out some of these links below. They'll contain some troubleshooting steps that you can go through.


Cameras Supported by National Instruments


Compatibility Test for IEEE-1394 and GigE Cameras with NI-IMAQdx


Troubleshooting GigE Vision Cameras


Time-Out Error with GigE Vision Camera

Jiwhan S.
Technical Support Engineer
National Instruments
Message 2 of 10



Thanks for replying. Most of these steps I went through beforehand except for the Camera Validator. After running the .exe, the report showed the same thing when trying to acquire an image. Even at smaller packet sizes and switching between network cards, I was still getting the timeout error. I disabled the firewall on the PC and updated the network driver to a GigE Vision Adapter and still no luck. Every value for the attributes of the camera are showing as PASSED when at the defaults settings of the camera in the compatibility report. The camera connects to NI-MAX just fine but no matter what I change I keep getting the same timeout error. Of course, when I change one of the attributes to a value outside of the camera's specs or something that the camera does not support I get a different error. 


MAX should be compatible with the Dalsa camera since it is GigE Vision but with no signs of it being able to grab an image without timing out makes me wonder if it actually is. Like I mentioned before, this is for testing purposes to see if a Dalsa camera is a valid option. I am open for any suggestion even if they are the simplest things. Thanks for the help. 

0 Kudos
Message 3 of 10

What version of Vision Acquisition Software are you using? What OS/network card/driver? Where did you get the adapter driver you tried?

Can you install Wireshark and do a trace when you're trying to Grab in MAX? We want to make sure the camera is sending GVSP (image data) packets. If so, can you attach the trace?

Can you attach your camera file here? This is located at C:\Users\Public\Documents\National Instruments\NI-IMAQdx\Data

and the extension is .icd.

Usually if you can interact with the camera fine but image acquisition times out, there's some attribute set like triggering such that the camera isn't sending data. The .icd file (with the settings we persist) and the Wireshark trace should help us answer that question.


We have tested compatibility with several different Dalsa cameras, but we don't have that particular one in house. In general we haven't had issues working with Dalsa GigE cameras. If there is a compatibility problem, I'd like to get to the bottom of it and work with Dalsa to figure out what's going on.





0 Kudos
Message 4 of 10



Vision Acquisition Software: Version 17.1

Windows 10

Information on Network Cards are attached

The adapter drivers were pre-installed when I got the PC

The trace and camera file are attached as well


Hopefully this helps. I'm sure I am able to grab images with this camera but whatever I am missing is beyond my current knowledge.

0 Kudos
Message 5 of 10
Accepted by edgemfg



Thanks for the quick response with all that info. I have no concerns with Win 10/VAS 17.1/Intel NIC/driver setup.


The trace shows no image packets, so that matches up with what you're seeing in MAX. This points to a configuration problem. Looking at the icd file, I saw this part that looked interesting:


CameraAttributes::DigitalIOControl::TriggerSelector = "Frame Active"
CameraAttributes::DigitalIOControl::TriggerMode = "On"
CameraAttributes::DigitalIOControl::TriggerSource = "Line 3"


Looks like the frame trigger is enabled on Line 3. Are you triggering the camera when you're acquiring in MAX? If not, you should turn that off.


Just in case that doesn't solve your problem, another technique would be:

1) close MAX 

2) go to Dalsa's software and acquire successfully however you were doing that before

3) delete the icd file that you sent

4) reopen MAX

5) try to acquire


These steps will mean that file with all the persistence settings will be regenerated based on whatever was in use when you were acquiring successfully with the other software (as long as you don't power cycle in between).


Hope this helps,


Message 6 of 10



Appears that I am still a rookie at these camera attributes. I was assuming Trigger Mode was Off already for all the Trigger Selectors since it was the default setting. I didn't even consider looking at the other Trigger Selectors to check. Looks like that did the trick and I am grabbing images just fine.


Thank you for helping me. Don't know how long it would have taken me to check that. 

Message 7 of 10

These days I'm also in trouble about the "Timeout" problem with DALSA GigE Vision Camera (Linea M4096), and I have tried every methods found on the Internet. But unfortunately none of them worked to me. However, with consistent effort, I just find the solution!!!


1、when you try to use NI MAX to open the camera, just Unselect the Teledyne DALSA Sapera GigE Vision Filter Driver in Ethernet properties before run NI MAX!!!


2、if you don't want to excute the previous step, you should not open Sapera Camexpert before you run NI MAX. Otherwise, you need to re-install your ethernet driver without unselect driver described before.


Ignore my bad english grammar, and have a good luck!

Message 8 of 10

I know this is an old thread, but I'm having a similar issue. I've gone through the basic troubleshooting - firewall, packets, drivers, and the camera works in Sapera. There are no other frame triggers active except the one I'm using (Line 1). One thing I've noticed is that MAX seems to generate an incomplete .icd file (attached); it only pulls two camera attributes before stopping. If that's the issue, do you know how to correct it?




0 Kudos
Message 9 of 10

Thanks for the tip.


Tried all other solutions and this was the right one.


The timeout problem happened on Nano C1280 and Nano C1940


Juan Navarro
0 Kudos
Message 10 of 10