Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

12-bit image displays bunches in only 16 gray levels

Solved!
Go to solution

I'm acquiring an image with a Basler Aviator avA2300-30km CCD camera, which has camera files for both 8-bit and 12-bit mode. I'm playing with 12-bit for the first time.

 

When I display the image with the histogram (see attachment), the gray-level depth is correct (0-4095) but it groups all the pixels in 16 evenly spread bins over the 4096 levels. I used the 16 Bit Display Mapping setting to map the pixels (see attached pic, this may well be what i'm doing wrong?).

 

You see in both images it renders with vertical stripes of light and dark, could that suggest it's wanting to read as 8 or 16 bit, and reading my 12-bit data incorrectly? (it's not just a mistake in my screenshot, that's what i actually see).

 

Why does it seem to give the correct number of gray levels, but not spread the pixels evenly as I'd like? This is the first time I've worked with anything but 8-bit images in labview so I'm assuming it's something simple I'm missing.


Cheers,
Dan

0 Kudos
Message 1 of 3
(1,377 Views)
Solution
Accepted by topic author Daaan
08-27-2015 04:09 PM

Hi,

I've take a look to the camera manual, this camera allows you to output 1 or 4 taps.

Is you problem occuring when you're in 1 tap mode?

Check the configuration (gain, correction) wich can be idependent for each tap.

Then check the camera data output mode 8,10 or 12 bit.

 

Hope this will help

NTA_LabView_certified_Developper.jpg
Message 2 of 3
(1,357 Views)

So simple, yet that was it. Buried in Image format controls of Pylon viewer (the camera config software) was the option to switch to 12-bit. I had just selected the 12-bit .icd camera file in MAX and had thought that was enough, but obviously had to change this setting too. Works with both 1 and 4 tap mode now too.

 

Thanks.

0 Kudos
Message 3 of 3
(1,341 Views)